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PART A – HOW TO START:
1.

General – Animal Identification and Numbering:
Individual identification:

Individual identification of animals is, of course, the basis of record keeping. The most common method of
identification is a plastic ear tag with the animal's unique number on it. Electronic identification by means for a
microchip implant is a method commonly used by game breeders.
We strongly recommend that at least two ways of individual identification be used, for the simple reason that
if one is lost (e.g. plastic ear tag torn or broken off), the animal can still be identified and the historical records
are therefore not going to get lost. The individual identification method for commercial (non-stud) animals
is not prescribed, but one of the following options is recommended:
• Electronic ID (EID) + ear tag (VID) or
• Ear tag + steel ear tag or
• Electronic ID (EID) + ear notches – especially for species like buffalo and rhinos where plastic ear tags
often get lost.
Calves should, if possible, depending on the particular species, be marked as soon as practicable after birth
with at least one of the above methods, usually a plastic ear tag or ear notches and/or electronic ID. When
calves are weaned, they should also be marked with a second method, e.g. electronic ID.

ID Number format:
The number format for commercial (non-stud) animals is not prescribed, but we recommend that the ID
number be made up of the Year of birth (e.g. 19 for 2019) + Sequence Number (e.g. 1 for the first calf born
in the year). In the above example, the animal's ID number would be 191. In BenguFarm it will be 1901 or
19001 or 190001, depending on how many calves are expected per year.
It is very important that there are no duplicate numbers in BenguFarm GAME as this causes many
problems. Preferably, different ID numbers should be used for animals of different species (herds) on the
same database, for example buffalo animals' sequence numbers 1 - 499 and sable animals' sequence numbers
501 - 999. Another option is to put in BenguFarm the species code at the front of the number, e.g. BUF191 for
the first buffalo calf of 2019 and SBL191 for the first sable of 2019 to make the ID number unique across
species. Please note: Use two (not just one) characters for the year of birth (e.g. 19 instead of 9 for animals
born in 2019) to prevent duplicate numbers being created in the BenguFarm database over the long term. See
paragraph 6, ID Methods and Numbering, for setting up default methods and formats in
BenguFarm.

Alternative numbers:

The ID Number (visual) is the primary number of an animal in the program. Animals are listed and sorted by
this number. However, BenguFarm provides for the recording of other numbers, where applicable, namely:
Microchip Number (EID), DNA Number), Animal Name, Computer Number (stud only), Animal ID [official]
(stud only), Biobank Number and Lot Number. To search for an animal on another number, go to
Animals > Search Animal.

2.

Install BenguFarm:
BenguFarm is the umbrella software product with various modules, namely GAME, BEEF, SHEEP &
GOATS and PIGS and GENETICS. Separate databases can be set up in BenguFarm for the various modules.
The module used for the management of game is called BenguFarm GAME. You will therefore install
BenguFarm, and then a game database is registered for the GAME module.
To download and install the programme from the Internet:
• Go to www.bengufarm.co.za > Downloads > Software. Follow the instructions on the page to download
and install the following software:
o Crystal Reports Basic Runtime for Visual Studio 2008 [18MB] (third party software used for
creating reports); and
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BenguFarm Installer 21 Apr 2022 [47MB]. Note: If you get a security warning, click "More Info >
Run" of "Allow" of "Run Anyway".
Go to Downloads > Updates and download the latest version [10MB] of the BenguFarm software and
install it. If Windows gives you a “Discard” or “Keep” option when starting to download the update file,
select “Keep”. If you have Avast, Avira, Kaspersky, McFee or Norton as anti-virus program on your
computer, it may be necessary to temporarily de-activate it (at own risk) as these anti-virus programmes
often block the update file without warning.
o

•

3.

Running BenguFarm for the first time:
Double click on the BenguFarm icon located on the Windows desktop. A message “Do you want to allow this
app (BenguFarm)…” will be displayed. Click “Yes”. BenguFarm will now open and the “Welcome to
BenguFarm” window will be displayed. On this window you should enter the following:
• Language: Choose the language in which you would like use the programme. (You can change it at
any time if necessary).
• Registered Username: This will appear on the BenguFarm welcome email. (E.g. Game Farmer
Farming CC). Please make sure that the name is correct, because you cannot change it yourself at a
later stage. (This name will be displayed on the bottom of all BenguFarm GAME reports).
• Primary Herd: Check “Primary Herd (e.g. Stud herd) what I want to run on BenguFarm”
o At Module, select “Game”.
o At Breed/Species, select the applicable species.
o At Description, complete the name of the species, or your primary species if you have more
than one species, (e.g. Sable).
• Basic (non-stud) Program Layout: Select this option if the screens, reports and fields that only
apply herds that register animals at SA Stud Book should be disabled. This option must therefore be
marked if it is a commercial (non-stud) herd.
• Secondary herd: Mark “Secondary herd (e.g. Buffalo) that I want to manage on BenguFarm” only if
a second species is applicable.
o At Module, select “Game”.
o At Breed/Species, select the applicable species.
o At Description, complete the name of the applicable species (e.g. Buffalo).
• Please read the instructions at paragraph 7 for the creation of additional herds (species)
before you decide on the option “Create the RespectiveHerds in the same Database”.
• Click on “Accept these Settings”.

4.

Register BenguFarm GAME:
A window will now appear with a warning that the programme has not been registered and that you can open
the programme for only five days without registering. If you want to register immediately, click on
“Register/Renew Registration Now”. On the Registration window at “BenguFarm Module (Spesie)”, choose
“Game”. To register, please contact Naomi Havenga at 082 696 8306 or send an email to
accounts@benguelasoft.co.za. Supply her with the following info:
• Your registered BenguFarm GAME username (as completed on the order form) and account number
(as on the Welcome e-mail you received from BenguelaSoft),
• The Computer Identification Code (code on the top left of the registration window),
• The number of herds or species for which you want to register the programme.
At Account Number, enter your BenguFarm account number (BPU....), at Access the access code that Naomi
will give you and then click Change Client Account Number. At Registration Code, enter the registration code
and at Access the access code that Naomi will give you and then click Register/Reregister.
For after-hours registration, please contact Mr. Leslie Bergh (082 801 2026) or Mr. Johan de Jager (083 305
1042) and supply the above information.
BenguFarm agents use Teamviewer software for remote (Internet) support. Teamviewer can, if
installed, be opened from BenguFarm on the main screen by going to Help > Teamviewer Remote Support. If
not installed, Teamviewer can be downloaded and installed at www.bengufarm.co.za > Downloads > Software
> Teamviewer Remote Support Software.
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Please note: If you have installed BenguFarm on more than one computer, the above registration process
necessary to be followed for each computer.

5.

Main window and general functions:
Main window:
•
•
•
•

To change the language in BenguFarm, go to Options > Change Language.
Access to all input windows, reports and data send/Import functions are obtained on the main
window by selecting the window from the menu at the top of the window or by clicking on the
corresponding shortcuts.
The largest part of the main window is used to view animals’ data. There are two options,
namely the Herd View and the Animal View.
To switch between the above two main screen options, click on the left side of the screen on Herd
View or Animal View.
o General:
▪ The animals that appear in the list of animals on the main window are controlled by
switching the general filters Active / Non-active / Male / Female on or off. The Group

▪

▪

▪

o

Filter (to the right of the Female filter) or the Choose Animals window (the
button)
can be used as additional filter.
Active animals are animals that are alive in the particular herd. Non-active animals
are animals that are not alive in the particular herd, for example animals that were sold or
died and animals that have never been in the herd but found in the pedigree or progeny
of animals that are in the herd.
Animal numbers are displayed by sex on different background colours:
o Female – Pink
o Male – Blue
o Sex Uncertain – Red
o Castrated – Orange
To view the new/updated data, click on the Refresh Screen icon.Please note: If
animals are moved to or from a group while that group has been selected with the group
filter, the animals in the relevant group will only be updated after the group filter has been
switched off (No Group Filter) and the relevant group has been filtered again.

Herd View: This layout is used to display certain important data of a group of animals (typically
all the animals in the herd) in Table Layout. For step-by-step help, go in the main menu to Help >
Help with Main Window > Herd View.
▪ To view the new/updated data, click on Refresh Screen.
▪ To fully display data in columns, click on Auto Width.
▪ To select which data should be displayed, click Display Options at the bottom of the
screen and select the relevant sections or fields.
•
To highlight certain animal data (e.g. cows with an average inter-calving
period of more than 400 days) as well as setting up rank values for the selected
criteria, click on Setup Herd Layout Highlighting (icon with small squares with
different colours). Use the Help function if necessary. Please note: If Activate
Highlighting and Rank Value is checked, the columns IDNr, Sire and Dam are
automatically highlighted green, blue and pink respectively.
•
To display columns for Vaccinations, Dosings & Supplements, Disease
Tests (e.g. Foot-and-mouth disease), Traits (e.g. condition score, general
appearance score), Procedures (e.g. castrate, tail docking) and/or Additional
Weights, click on the Set Up My Columns to Display (icon at the top).
• To save the column selections and highlighting options as default for
the particular herd, click on Save Options as Herd Default under the heading
Save/Load Layout. The saved options will automatically load the next time the
herd is opened.
• To save a layout for re-use, give it a name at Save Layout As under the
heading Save/Load Layout and click on the Save icon.
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•

▪

▪

▪

▪

▪

▪

▪

▪

▪
▪
▪
o

To load a saved layout, select the particular layout at Load Saved Layout and
click on the Load icon.
• Please note: Management groups column: If an animal is linked to more than
one management group, only one of the groups will be displayed.
To create a report of the data displayed in the Herd View, click on Display Report.
Please note: All columns and all animals will be included in the report. Click on View
Options to select and deselect columns you wish to include in the report. Use the filters at
the top of the window to change the selection of animals which should be included in the
report.
To view a specific animal’s (or sire or dam) data in the Animal View main
screen layout, click on the relevant animal's ID number. To return to the relevant animal
in the Herd View, click on the Herd View link.
To group records, click on the column heading and hold the mouse button. Now move
the mouse to the open section at the top of the report where there is written "Drag a
column header here to group by that column" and release the mouse button. The column
name will now be displayed in this open section. Records can be grouped on more than
one column values. To remove the group, right click on the column heading and select
"UnGroup".
To sort records, click on the appropriate column heading. To sort in the reverse order,
click a second time on the column heading. To sort by multiple columns at once, hold the
SHIFT key on the keyboard and click on the column headings.
To filter records, click on the right of a column heading on the filter button. A list of all
the values that appear in that column will be displayed. To display only records that have
a specific value, click on that value. You can also click on "(Custom)". A screen will open
where, for example, you can select to display all records with a value greater than a
certain value. Note that more than one column can be filtered at a time. To remove a
specific column's filter, click "(All)" at the filter options of that column. To remove all
column filters, click on the X at the bottom left of the main window.
To temporarily move a column to another position in the table, click on the
column's heading and drag it to where it should be placed and drop it. When the relevant
screen is closed and reopened, such a column will be displayed again in its original
location.
To temporarily remove a column from a screen, click on that column's heading and
drag it until it displays a large cross and drop it. When the relevant screen is closed and
reopened, such a column will be displayed again.
To record certain data (e.g. Edit Animals (Table Layout) or Sales, Deaths and Culls) for
a group of animals, mark the animals in the "S" column and select the appropriate
recording screen from the top menu or click on the corresponding icon.
To link animals to a group, mark the animals in the "S" column and click Link Animals
to Group.
To display animals in the My Reports screen, mark the animals in the "S" column
and click Display in My Reports.
To copy the data to the computer’s "Clipboard", click Copy to Clipboard.

Animal View: This option consists of display (view) windows which are used to display the data
of a single animal. There are various display windows available where data from the animal
selected at the top left of the main window (obviously only when animals are already in the
BenguFarm database), is displayed. There are for example display windows for general data, birth
data, reproduction and progeny averages, pedigrees, photos, etc. For step-by-step help, go in the
main menu to Help > Help with Main Window > Animal View.
▪ The display windows are divided into four groups or sub-windows. You can select to view
one display window from each group of sub-windows at a time. Simply click on the tab of
the applicable display window at the bottom of the group of display windows.
▪ To hide display windows which are not used, click on the "Display" menu and under
the heading Main Window View Screens remove the tick mark next to the appropriate
display window.
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To create a report of the data being displayed on a display window, click on the
printer icon in the right-hand top corner of the relevant display window. For more display
settings, see paragraph 8.
▪ To select an animal (which is already in the BenguFarm database) to display on the
main window, click on the pink or blue box at the top left of the main window or press
Ctrl+Z on the keyboard. The animal can be chosen from the list or the IDNr can simply be
typed. The arrows left and right are used to move to the previous and next animals in the
list.
▪ To enlarge or reduce sub-screens, move the cursor on the brown line between the
sub-screens and drag and drop to the desired size.
o Tip: To select the Herd View (instead of the Animal View) as the default layout for the
main window, go to Display and click the Use Herd View as Default Main Window Layout option.
For further assistance with the use of the main screen, go to Help > How to Use this Window.
Tip: If an animal(s) that you expect to be in the animal list are not found, check the following:
o Are you in the right herd?
o Have the correct general animal filters been selected? If only active animals are listed, check that
the animal may not be non-active.
o If so, was the correct group filter selected?
o If so, were the correct column filter(s) selected? Look at the bottom left of the window for active
column filters.
o Are the animals sorted on ID number?
o Is the number format of the animal concerned correct? (e.g. A210001, A 210001, A21001).
▪

•
•

Choose Animals window:
• The Choose Animals screen is a used everywhere in BenguFarm to choose animals for recording
data or to include in a report. The user can choose the animals by hand (right hand side of screen) or
choose the animals from a group(s) and/or filter(s) (left hand side of screen). The screen is opened
when the user click on the
necessary.

button in a recording or report window. Use the Help function if

General Features – All windows:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

To open a window, all other windows must be closed. If a window is minimized, another window
cannot be opened.
BenguFarm can only be closed if all the windows are closed.
To quickly find an animal on the main screen or other drop-down list, open the list and enter the
animal's ID number. The same goes for finding an item in any type of drop-down list.
Sex indication on sceens: Column heading is Male. Male animals have a tick mark, females not.
The general animal filters (Active / Non-active / Male / Female) are displayed on all screens where
animals can be selected at the top of the relevant screen as four squares. The description of each filter
can be displayed by moving the pointer over the box.
On all recording windows fields compulsory/important to complete are on a yellow background.
Fields with a white background is optional to complete.
To move from one field/column to the next where data need to be entered, use the "Tab" key or die
“→” key.
To go to the next or the previous line where data need to be entered, use the “↓” and the “↑” keys.
Numeric fields (e.g. weight, price) MUST have a value (0 or other).
To select a date using the calendar, firstly select the year, then the month, then click on the day.
To edit or delete existing data, see paragraph 14.
To sort or filter records on a window or to move a column to another position in the table or
to temporarily remove a column from a screen, see the instructions above at Main Window > Herd
View.
The full description of a column heading can be displayed by moving the pointer over the column
heading.
To choose animals for multi editing or deletion, select the S (Select) column and change the relevant
data at the top of the screen in the Multi Edit / Add New part of the screen.
It is recommended that costs and prices be recorded without VAT.
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• To create a new record at Settings, cliick on the “+” at the bottom right of the window. To delete a
record, cliick on the “-” at the bottom right of the window.
• A step-by-step Help function is available on most windows at the top right of the screen. Please use it
– you will be surprised how easy it works.

Reports and Recording Lists:
•
•

•

•

6.

All reports can be created through the Reports menu item.
Reports with "(recording list)" behind the report name are reports with some blank columns in the
report. The purpose is to print the relevant report (recording list) and take it to the camp to
record data on it, e.g. a Trait Lists (recording list) on which horn measurements can be recorded. The
benefits of using printed recording lists are:
o Animals are sorted – easy to record data later in BenguFarm;
o Easy to check if all animals are done;
o All necessary info is printed on the recording list;
o Does not waste time writing animal ID numbers;
o Errors with animal identification can easily be detected.
When a report is created (Display Report), there is always options to print or to the export the report.
With the Export option a report can be saved in various formats, e.g. pdf or Excel or the report can
be e-mailed directly from BenguFarm to a contact. Please note: Direct mail sending, for certain technical
reasons, does not always work. If you have a problem with this option, contact your BenguFarm agent for
help setting up the SMTP Direct Email Option [Settings > Herds > E-mail > Use SMTP Direct Email].
To create a report containing animals from all herds on the relevant database (where applicable), go to
the "ALL" herd [File > Change Active Herd To > ALL].

Settings:
Tip: To change the language in BenguFarm, go to Options > Change Language.
It is very important that the settings for each herd (species) are done before you start using the
programme to ensure that the programme functions correct and optimal.

Herd settings:

Go to Settings > Herds. Complete/change the information, where necessary, under the following headings on
the grey area of the window. Please note: First do the General settings, secondly the Service
Providers and then the rest. For most settings, default values or options have been selected. Check these
default settings and only change if necessary for your specific needs.
Please note: Fields with a yellow background is compulsory/important to complete. Fields with a
white background is optional to complete.
o General:
▪ Name (required): E.g. Sable or Blue Wildebeest (not Golden Wildebeest).
▪ Description (optional): E.g. Sable Herd.
▪ Owner (optional): E.g. James Brown.
▪ Farm Name (optional): E.g. Sweet Water.
▪ BenguFarm Module (required): Game.
▪ Animal Species (REQUIRED and VERY IMPORTANT): E.g. SBL – Sable. This setting determines
certain species-specific default settings such as pregnancy period and horn measurements. If you
change this, close the programme, open it again and go to File > Support > Recalculate Summary
Data for the change to take effect.
▪ Herd Type (required): Select Commercial, except if animals will be registered with SA Stud Book,
then select Stud.
▪ HDM (registered Herd Designation Mark of the herd – only applicable to herds registered with SA
Stud Book): E.g. ABC. Contact Herman Labuschagne at SA Studbook at 051 4100 900 or
herman@studbook.co.za to register a HDM and Prefix (next field). If you do not have a registered
Herd Designation Mark for this herd/species, leave this field blank.
▪ Prefix (registered prefix or herd name - only applicable to herds registered with SA Stud Book): E.g.
Thaba Tholo.
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Society Member No (only applicable to herds with SA Stud Book as registration service provider):
Complete the number with preceding zeros so it is seven numbers and the species code at the end,
e.g. 0699999SBL.
▪ WRSA Member No (only applicable to WRSA members): E.g. 12345.
▪ Invoices Made Out To (optional): Complete the name of the person or business to which the
invoices should be made out to.
▪ VAT No (optional): Complete the VAT number.
▪ Postal Address (optional): Complete the postal address.
▪ Postal Code (optional): E.g. 2500.
▪ Land Code (optional): E.g. ZAR.
▪ Contact Person (optional): Click on the shortcut icon on the far right (Auto create herd contact from
herd details). Now click on the shortcut on the right (which looks like a red notebook) to open the
Contacts window and fill in the missing information, specifically the name & surname, cell phone
number and email address. Save. Now select the contact from the contact list. Please note: The
contact details completed here (name and surname, cell number and email address) will be printed at
the top of all reports.
▪ Breeder, Owner and Keeper (optional): Select the contact you set up above, e.g. Long Horn Game
Breeders.
Service Providers (only applicable to herds with SA Stud Book as service provider):
▪
Registration, Performance Testing and Breeding Values: Select the service provider of the
herd with each.
▪
Use Logix Direct File Upload Functionality (optional - only applicable to Logix users – refer
www.logix.org.za – please read the note on the window:
•
Login Username: Enter your Logix username.
•
Login Password: Enter your Logix password.
•
Send E-mail Confirmation of Received Data To: Enter your email address here.
▪ E-mail Addresses:
•
If Studbook was selected above as service provider for Registration and Performance
Testing, please ensure that the E-mail Matings, Birth Notifications, Transfers and
Cancellations To as well as E-mail Performance Test Data To addresses are
edata@studbook.co.za.
ID Methods and Numbering: (Refer paragraph 1 for general information on ID Methods and
Numbering of animals)
▪ Default ID Format: The default ID format is used to determine the format of the Animal ID Nr
(visual) in BenguFarm GAME, according to the animal’s Herd Designation Mark (HDM) (only applicable
to herds registered at SA Stud Book), Year and Sequence number. The default ID format in
BenguFarm GAME is HHHHYYNNNN. The HHHH indicates there is provision for maximum 4 characters
for the Herd Designation Mark (if applicable), the YY indicates there is provision for maximum 2
characters for the year of birth and the NNNN indicates there is provision for maximum 4 characters
of the sequence number. E.g. if the herd designation mark is ABC, the year of birth is 2020 and the
sequence number 123, the ID Nr will be created as ABC200123. Game breeders usually use only the
year of birth and sequence number to identify animals. In this case, the default ID format can be set
as YYNNNN or YY-NNNN.
▪ Default Main ID Method (Permanent ID): For game the default permanent ID method is usually
an Electronic ID.
▪ Default Sub ID Method (Visual ID): For game the default visual ID method is usually an Ear tag.
▪ Separate Sequence Numbers for Heifers and Bulls: Check this option only if (for this herd) one
serial number range for heifer and bull calves is not used. At Sequence Number Method the
appropriate option should be selected for Male and Female. If continuous series sequence numbers
(in this herd) are used for heifer and bull calves (e.g. 1-100 for heifer calves and 101-200 for bull
calves OR 1-100 for heifer calves and 1-100 for bull calves), tick Continuous Sequence Numbers at
both sexes.
▪ Apply Sequencing Settings of First Herd to All Herds: Select this option if you have two (or
more) herds on the same database and you use one sequence number range for both herds.
BenguFarm will then allocate the next available sequence number irrespective of the herd when new
calves are recorded on the Calving screen.
▪

o

o
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Create IDnr (Visual) from EID (Microchip Number) where no IDnr is specified: This option
should only be chosen if only microchip/electronic identification is used and BenguFarm GAME should
automatically create visual Indris from the microchip/electronic identification numbers that are
imported into BenguFarm from an electronic identification reader or -scale.
Mating, Pregnancy and Calving:
▪ Current Calving Season: Ignore - see Calving Season settings below.
▪ See Appendix C on how Minimum Age of Heifers at First Mating, Av. Period from Calving to
Mated Again and Normal Pregnancy Period are used in the calculation of Expected Calving Date.
▪ Synchronisation (if applicable): Complete the # Days from Insert to First Injection; # Days from
Insert to Second Injection; # Days from Insert to Remove and # Days from Remove to AI / Lapa.
▪ Other fields: Check the default values and change only where necessary for the specific species.
Performance Testing:
▪ Ignore – not applicable presently to game.
E-mail:
▪ Use Windows Configured E-mail Program: Check this option if you use any e-mail program other
than Microsoft Outlook.
▪ Use Microsoft Outlook as E-mail Program: Check this option if you use Microsoft Outlook.
▪ Use SMTP Direct Mail: Check this option only if your BenguFarm GAME agent recommended it
when you have problems with your regular e-mail program.
▪ Send E-mail Direct: Do not check this option.
▪ Display E-mail Success: This option must be checked.
Default Folders for Files:
▪ During the installation of BenguFarm, a folder “BenguFarm” is automatically created on the
computer’s local disk (C:\BenguFarm\). In this folder is a subfolder “Game” with three sub-folders,
namely “Imports”, “Exports” and “Backups” are created with sub-folders for your herd(s) in each of
them. In BenguFarm GAME these three sub-folders are then automatically set as the default folders
where BenguFarm GAME data can be saved. Please note: The default place for saving backup files
(C:\BenguFarm\Game\Backups\[Herd]) is NOT a safe place, since the backup will be lost if the
computer is stolen or get damaged. It is VERY IMPORTANT to save backups in a SAFE PLACE,
e.g. a cloud-based place like Dropbox, GoogleDrive or OneDrive and/or on an external hard drive or
memory stick. Click on the button with the three dots to select a save place.
▪ Default Folder where Photos will be Saved In: Do NOT change the default directory - it is
correct.
Map Network Drive at Start-up: If you want to put the BenguFarm database on a network, please
contact Mr. Leslie Bergh at leslie@benguelasoft.co.za or 082 801 2026 for instructions to set it up.
Reminders:
▪ Check the default values and change only if necessary.
Body Measurements:
By default, all horn measurements in BenguFarm are recorded in decimals (e.g. 40.375). On the main
screen and on all reports the results are displayed in fractions (e.g. 403/8). If you want to display the
measurements in decimals instead of fractions, remove the check at Display Horn Measurements with
Fractions and click Save.
▪ Cows’ Frame Size: Ignore – not applicable in game.
Scoring:
▪ Ignore – the default is correct.
Other:
▪ Check the default values and change only if necessary.
▪ Default Group Category: Select the group category that will be used most often.
▪ Allow Sales, Deaths and Culls Records for Animal in Each Herd: Check this option only if you
have more than one herd (on the same database) and you want to record more than one sales record
per animal.
▪ Allow Data Recording in “ALL” Herd: Check this option if you have more than one herd (on the
same database) to allow certain data (pregnancy tests, vaccinations, illnesses and treatments, camp
and group movements, purchases, procedures, etc.) to be recorded in the ALL herd.
▪

o

o
o

o

o
o
o
o

o
o

Groups – Calving seasons, camps and management groups:
See paragraph 17 for the purpose, setting up and use of calving seasons, camps and management groups.

11

Traits per Species:

To change the traits normally recorded for a specific species, the order in which the traits are listed
and the unit of measurement (inches or cm), go to Settings > Traits per Species. These settings will find
application in the Darting Data > Horn & Other Measurements window and the Performance Testing > Horn &
Other Measurements window. Please note: The selected list will only be displayed if the relevant animal’s
species is correctly recorded.

Contacts:
To create Contacts for people or businesses that will be used several places in the program (e.g. Owner,
Manager, Inseminator, Buyers, Veterinarians, Consultants, Inspectors, etc.), go to Settings > Contacts, click
on the "+" (lower right corner of the window) to create a new contact record. Please note: The Business
field (person or business name) is the field that will be displayed in selection lists and is the only compulsory
field to complete.

Other Settings:
All the other lists have default items already included in the particular list. You cannot edit or delete these
default items but, where necessary, you can add additional items by clicking on the “+” at the bottom right of
the window. The Medicines list is the one list that will need to be extended with your own list of medicines.
Tip: In certain settings (e.g. Camps; Vaccines, Dosings & Supplements; Medicines as well as Diseases, Injuries
& Parasites) there is an "In Use" column. Items marked with In Use are displayed in the relevant menu at the
top of the list and the rest below to make it easier to select an item. Some items also have a "Device" column.
Items not marked with Device are hidden in the relevant drop-down list on the Mobile app and on the
APR500/600 EID reader so that the list is shorter.

7.

Create additional herds (species) and navigate between herds:
•
•

•

•

BenguFarm GAME makes provision for more than one herd (e.g. different species) to be created in the
programme without additional costs, provided of course that all the animals are the property of one
owner.
A separate herd must be created for each species. Additional herds (species) can either be created
on the same database or on separate databases.
o If animals are shared between herds (e.g. bulls used in two herds) and/or if animals are moved
from time to time between herds (e.g. two separate sable herds), we recommend that the herds
are created on the same database. Creating a second herd on the same database also has the
advantage that certain settings (e.g. Camps and Contacts) do not need to be done separately for
each herd and that it is not necessary to make a separate backup of each herd. It also has the
advantage that, through the “ALL” herd option, reports and recording lists can be created that
include all animals, regardless of herd.
o The only instance where we would recommend that you create additional herds on separate
databases is if the different herds' record keeping in BenguFarm is going to be done by different
people, e.g. the manager of farm A keeps the records of farm A's herd(s) on his computer and the
manager of farm B keeps the records of farm B's herd(s) on his computer. This then has the
advantage that each manager can work independently of the other manager(s) on BenguFarm
and that a separate database backup of each farm's BenguFarm data can be made and, for
example, restored on the owner's computer without overwriting the other farm’s data.
o If in doubt on which option to choose or you need more info on the setup of herds,
please consult with your BenguFarm GAME agent.
To create a second herd (species) on the same database, go to Settings > Herds > General and
click on the "+" at the bottom of the window. Enter a name (e.g. Buffalo), select the Animal Species and
do the rest of the settings for the herd. Click Save and Exit. Please note: Some general herd settings will
be entered automatically if it was entered for the first herd (species) that was created. It is therefore
recommended that the General settings of the first herd (species) are done (see paragraph 6)
before the additional herds (species) are created. Ensure the Animal Species field for each
herd (species) is entered – this is very important.
To create a second herd on a separate database, go to Options > Databases. Click on + Add New,
choose the Species (Game) and complete a name for the database (e.g. Buffalo) in the field Database
Description. Click on Save and Exit.
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•
•
•

•

If necessary, please contact Naomi Havenga at 082 696 8306 or send an email to
accounts@benguelasoft.co.za to register additional herds and/or databases.
To switch between herds in BenguFarm GAME, go to File > Change Active Herd to. Click on List All and
Select, select the appropriate herd from the drop-down list and click Activate.
Please note: If more than one herd is created on the same database, BenguFarm GAME will
automatically create an ALL "herd". The ALL herd’s main purpose is to create reports that will include
animals in all herds in the database. Normally one will not work in the ALL herd, since only certain data
recording can be done in the ALL herd.
o To allow certain data (e.g. matings, pregnancy tests, vaccinations, weights not for performance
testing) to be recorded in the ALL herd, go to Settings > Herds > Other and check the option
Allow Data Recording in “ALL” Herd.
o If two (or more) herds (species) are created on the same data base, try not to use the same ID
numbers for animals in the two herds, to prevent confusion with identification if working in the
ALL "herd". One way to do this, is to add a code indicating the species before the number, e.g.
B19001 for buffalo and S19001 for sables. If one set of numbers is used for all animals, regardless
of the herd they are in, go to Settings > Herds > ID Methods and Numbering and select the Apply
Sequencing Settings of First Herd to All Herds option.
To move animals of the same species between herds, see paragraph 28.

8. Display settings – Main window and other:
The purpose of the Display options is to customise BenguFarm for your specific needs by hiding certain
windows and certain fields on some windows in BenguFarm GAME that is not used. This is specifically handy
for commercial (non-stud) breeders who want to hide functions and windows that are not used. To
customise your BenguFarm GAME in this way to suit your specific needs and make it more user friendly, go to
the Display menu item:
o To select the Herd View (instead of the Animal View) as the default layout for the main
window, go to the Display and click the Use Herd View as Default Main Window Layout option.
o To select or hide fields displayed on the Herd View of the main screen, go on the Herd View
to View Options. To save your selection of fields as the default settings for the specific herd, click Save
Settings as Herd Default.
o To hide functions and fields that only apply to stud studs on the Main Window, Calving
Window and Add & Edit Animal Window, go to Display > Customize Fields Displayed in Main
Window View Screens, click the Mark Default Commercial Field Selections option and click Save.
o To hide functions on the Main window and/or fields on the Calving window and the Add &
Edit Animal window which is not used, go to Display > Customise Displayed Program Items.
Make a tick mark in the box in the yellow area next to "Display only the marked Functions and/or
Fields…”. Click on the “+” next to Main Window Functions, Add & Edit Animals window and Calving
window to check and, if necessary, change the functions and/or fields you want to be displayed. Click
on Save. Please note: Functions and/or fields that are hidden this way will be applicable to all herds
in the relevant database.
o To hide the display windows on the Animal Layout of the main window that are not used,
go to Display and below the heading Select Main Window Animal Layout View Screens uncheck the
applicable display window. [Use the Help function if necessary]. Please note: Functions and/or fields
that are hidden this way will only apply to the applicable herd. If it should apply to all herds in the
relevant database, check the option Apply to All Herds in this Database and click Save.
o To display the growth between measurements (instead of from birth) on the Horn
Measurements view screen on the Animal View of the main screen, go to Display and under
the heading Horn Measurements View Options, select the Show Growth Between Measurements
option.
o To hide specific fields on certain lookup screens (General, Birth, Last Mating, Reproduction &
Progeny Averages, Performance Testing and Breeding Values) on the Animal View of the main window
that are not used, go to Display > Customize Fields Displayed in Main Window View Screens. Click
on the appropriate view screen (e.g. General) and uncheck the fields you do not use. Do the same for
the other view screens. When done, click Save. Please note: Fields on view screens hidden in this
way will only apply to the applicable herd. If it should apply to all herds in the relevant database,
check the option Apply to All Herds in this Database and click Save.
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o

To hide specific fields on the Progeny display window that are not used, go to Display >
Customize Progeny View Screen Columns. Uncheck the applicable fields you do not use and then click
on Exit. Please note: Fields on the Progeny display screen that are hidden this way will be applicable
to all herds of all modules, where applicable. Certain fields that do not apply to a specific BenguFarm
module will be automatically hidden.

Tip: To select an animal (e.g. your favourite breeding bull) to be displayed by default on the main window’s
Animal View when you open BenguFarm GAME, go to Settings > Herds > Other > Animal to Display when
Opening BenguFarm GAME.

9.

Step-by-step help function:
A step-by-step Help function is available on most windows. This function is designed to take the user stepby-step through the functions of each window. We strongly recommend that you use these step-bystep Help functions until you are familiar with the applicable window. The Help function is
activated by clicking on the "Help" button on the applicable window. Then choose the applicable function
you want to perform and follow the step-by-step instructions. Please note the flickering arrow in one of the
corners of a Help window. This arrow indicates where on the window data should be entered or the
function should be activated. Click on the ">>" button to go to the next step. Click the "<<" button to go
back to the previous step. Click on the “X” button to close the Help window.
Click on the "Help" button on the main window for help with certain basic functions in
BenguFarm GAME, namely General, Handling of Multiple Herds, Herd View and Animal View. The latest
version of the BenguFarm manual can also be downloaded and opened here.

10.

Import animal data from external sources: (if applicable)
•
•
•
•
•
•

•
•

BenguFarm is now ready for animal records to be imported or manually recorded. The first choice is, of
course, to import data from some electronic file(s) if such file(s) is available. If such file(s) (see below) is
not available, the data must be manually recorded. See paragraph 11 for instructions for this.
Depending what data is available, data can be imported from one (or in cases where required more than
one) of the following sources. Please contact your BenguFarm agent if you need any help with importing
data.
Please note: Make sure you are in the correct herd where the data should be imported.
To import animal data which was recorded on Excel, see Appendix A or contact your BenguFarm
GAME agent or Mr. Leslie Bergh at leslie@benguelasoft.co.za or 082 801 2026.
To import Logix data, see Appendix B, paragraph 2.
To import data from another BenguFarm GAME user: If you have bought animals from a fellow
BenguFarm user, he can create a BenguFarm Animal Transfer with the relevant animals’ data [Data
Send/Import > Send > BenguFarm Animal Transfer File] and send it to you. You can import this file at
Data Send/Import > Import > Database > BenguFarm Animal Transfer File. Please note:
o
Make sure you are in the correct herd (species) where the data should be imported.
o
If an animal(s) with the same ID number exists in another herd(s), ensure the option Only Search
in Selected Herd is checked.
o
Below the Existing heading, check that the Status of the animals are correct.
To view the general data of an animal on the main window, go on the Animal View to the General
view window or go on the Herd View to the General, Identification and Birth sections.
After the animal data has been imported, the following information can be added, where
available:
o
To record purchase data (purchased from whom, purchase date, price, etc.) of the above
imported animals, see paragraph 12. Use the Help function if necessary.
o
To assign animals to camp groups, see paragraph 17. Use the Help function if necessary.
o
To record horn measurements, go to Performance Testing > Horn and Other Measurements
OR go to Other Data > Darting Data > General.
o
To record the book and market value of individual animals, go to Animals > Edit Animals
(Table Layout). Use the Help function if necessary. Please note: When purchase data of animals
is recorded (Other Data > Purchases), the purchase price will automatically be entered as the
book value of the animal, provided that the book value of the animal was not already recorded.
o
To record the average tax and market values for various categories of animals, go to
Reports > Animal Lists and Numbers > Animal Numbers and Values. Select Calculation Method at
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the top left of the window and click on the Add and Edit Animals Numbers Calculation Methods
icon, complete the Market and Tax Value columns and Save.
To mark your breeding bulls as breeding bulls, go to Animals > Add and Edit Animals
(Single animal layout), highlight the applicable bull, make a tick mark in the field "Breeding/AI
Bull" and click Save. Bulls marked as a breeding bull are listed separately under the “Breeding
Bulls” category on the main screen’s Herd View in the Category column as well as in the Animals
Numbers and Values report. The breeding bulls will also be listed on top the list of bulls when
recording matings.

Create animal records manually: (if applicable)
•

•
•

•
•

•

•
•
•

If the basic animal data of all animals in the herd couldn’t be imported (refer paragraph 10), then it should
be recorded manually. For this purpose, it is recommended to use the Add Animals Wizard window
(Animals > Add Animals Wizard) to quickly and easily create animal records. [The Add and Edit Animals
window (Single Animal Layout) screen can also be used, but the Add Animals Wizard is the easiest way to
create new animal records]. Please use the calving window (Reproduction > Calving) to enter
calvings.
On the Add Animals Wizard window, under “What do you want to do?” choose the option applicable to
your herd and available data, e.g. Add a New Animal: Minimal Data – Commercial Animal and follow the
instructions.
The minimum data necessary for an animal record is ID no. (Farm), Sex, Species, Birth date, Status
(Active = Alive/In herd, Non-Active = Dead/Not in herd) and Registered or Commercial. [Please note: If
an animal’s precise birth date is unknown, then please enter an approximate date, e.g. 01 Oct 2014 for
animals born in 2014 and check the Birth Date Uncertain box].
If you want to link the animals to a camp on this screen, the camps must be set up first. (See
paragraph 17 of this manual). If Animal in No Camp is selected at Camp, what is entered by default in
Date in Camp and Reason will not be saved, so leave it unchanged.
The field Herdmark (if applicable) and Year (of birth) will be completed automatically. As soon as the
Sequence number is completed, the program will automatically create the IDNo (Visual) in the
format set up at Settings > Herds > ID Methods and Numbering> Default ID Format. (See paragraph 6 of
this manual). If needed, the default IDNo can be changed.
Begin with the oldest animals in the herd and work down to the younger animals. If you want to
record the dam and/or sire of an animal, first create an animal record for the applicable parent(s).
When you create the animal record, you can then choose the parent(s) by clicking on the dropdown next
to the parent field and choose the parent from the list. If the sire or dam is not in herd, create him/her
with Status as Non-active.
To view the general data of an animal on the main window, go on the Animal View to the General
view window or go on the Herd View to the General, Identification and Birth sections.
To change (or delete) an animal record, see paragraph 14.
After the animal data has been created, the following information can be added, where
available:
o
If the purchase data (e.g. purchase date, purchase price, bought from) have not yet been
recorded on the Add Animals Wizard screen, it can be recorded on the Purchases screen. See
paragraph 12. Use the Help function if necessary.
o
To record horn measurements of animals recorded above, go to Performance Testing > Horn and
Other Measurements OR go to Other Data > Darting Data > General.
o
To record the book and market value of individual animals, go to Animals > Edit Animals
(Table Layout). Use the Help function if necessary. Please note: When purchase data of animals is
recorded (Other Data > Purchases), the purchase price will automatically be entered as the book
value of the animal, provided that the book value of the animal was not already recorded.
o
To record the average tax and market values for various categories of animals, go to
Reports > Animal Lists and Numbers > Animal Numbers and Values. Select Calculation Method at the
top left of the window and click on the Add and Edit Animals Numbers Calculation Methods icon,
complete the Market and Tax Value columns and Save.
o
To mark your breeding bulls as breeding bulls, go to Animals > Add and Edit (Single animal
layout) > General Data, highlight the applicable bull, tick the field "Breeding/AI Bull" and click Save.
Bulls marked as a breeding bull are listed separately under the “Breeding Bulls” category on the main
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screen’s Herd View in the Category column as well as in the Animals Numbers and Values report. The
breeding bulls will also be listed on top the list of bulls when recording calvings.

12.

Purchases – Animals:
•
•

•
•
•

•
•

13.

Check if all the animals are on record:
•
•
•
•
•

14.

To import or record the animal data of purchased animals, see paragraphs 9 and 10 above.
To record (or edit/delete) the purchase data (purchased from whom, purchase date, price, etc.) of
purchased animals, go to Other Data > Purchases. Use the Help function if necessary. Please note: If
animal records are created manually by using the Add Animals Wizard screen, the purchase information
can be recorded on that screen.
To create a report of animals that were purchased, go to Reports > Purchases, Auctions, Sales,
Deaths and Culls > Purchases.
To view the purchase data of an animal on the main window, go on the Animal View to the
General view window and scroll down to the purchase data fields or go on the Herd View to the Purchases
section.
To ensure that the breeding bulls are displayed on top of the list of bulls on the Natural
Matings and AI windows, go to the Add and Edit Animals (Single Animal Layout) window; find the
applicable bull and mark (highlight) the bull. Make a tick mark in the field "Breeding/AI Bull" and click
Save. This will also ensure that active breeding bulls are listed separately in the “Breeding Bull” category
on the main screen's Herd View in the Category column as well on the Animals Numbers report (Reports >
Animal Lists & Numbers > Animals Numbers).
If you need help with downloading Logix data of registered animals you purchased, please
contact SA Stud Book at telephone number 051 4100 900 or send an e-mail to help@logix.co.za and ask
her to send you the 5-generation Logix GAMEDATA file of the animal(s).
To link animals to camp groups, see paragraph 17. Use the Help function if necessary.

To view the important data of animals in table layout on the main screen, go to the Herd View.
To view the data of a single animal on the main screen, go to the Animal View, select the animal's
ID number in the box (pink or blue) at the top left of the main screen, then click on the relevant view
window's link.
To check if all the animals are in BenguFarm GAME, you can create a herd list report by going to
Reports > Animal Lists and Numbers > Herd List.
To create an animal numbers and values report which will show the number of animals in the herd
per category (calves, cows, bulls, etc.), go to Reports > Animal Lists and Numbers > Animal Numbers and
Values. See paragraph 17 for more information on how the categories are defined, etc.
To check if duplicate animal records have been created and/or imported, see paragraph 35.

Edit or delete data
•

•

To edit or delete general animal data (e.g. sex, birth date, ID number, sire, dam and status), there
are basically three windows that can be used, namely:
o Animals > Add and Edit Animals (Single Animal Layout): Use this window for changes to
single animals or unique fields such as ID No. Use the Help function if necessary.
Tip: The Add and Edit Animals window can be used for single animal editing as well as multianimal editing. To select a single animal, click ONCE on the animal's number so that the number is
only highlighted. To select multiple animals, DOUBLE click on an animal's number so that a tick
appears in the box next to the number. Then click Multi Edit at the bottom left of the window.
o Animals > Edit Animals (Table Layout): Use this window for the same change to multiple
animals, e.g. to change the calving season for a group of calves. The screen can also be used to
delete animal records, if necessary. Use the Help function if necessary.
o Reproduction > Calving window: If you want to change something (e.g. a calving date) on an
existing calving, choose the applicable cow, click on the “N” next to her number and choose the
calving you want to change. Use the Help function if necessary.
To edit or delete specific (non-general) data (e.g. matings, pregnancy tests, vaccinations, illnesses
and treatments, procedures, purchases and sales), go to the window where the relevant type of data was
originally entered. If, for example, sales records need to be changed, go to Other Data > Sales, Deaths,
and Culls. To display the existing data that needs to be changed, click at the top right of the window on
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Load Existing Records. When the animal or group of animals was selected, this animal(s) data can be
edited and saved. If the same change needs to be made for several animals, mark the specific animals
which data need to be edited with a tick in the first ("S" = Select) column. Now the relevant data can be
changed in the Multi Edit / Add New area at the top of the window and saved. Use the Help function if
necessary.
The Data Navigator window [Animals > Data Navigator] can also be used to edit data and delete
records of various types. Use the Help function if necessary.

Backup and restore of the database(s) and other info:
•

•

•

•
•
•
•
•

•

VERY IMPORTANT!!! Please read the following paragraph carefully.
o The BenguFarm database, photos, et cetera are NOT kept in the cloud, in other words it
is kept on the computer itself. This means that if the computer is stolen or the hard drive get
damaged or a virus damages the computer files, the BenguFarm data, et cetera will be lost.
o It is critically important to make a backup of your BenguFarm database(s), saved
report layouts, photos & documents, etc. on a REGULAR basis, especially after you have
added or edited some data, before you let someone else work on your computer, etc.
o It is equally important to save the backup in a SAFE PLACE, e.g. a cloud-based place like
Dropbox, GoogleDrive or OneDrive and/or on an external hard drive or memory stick. Keep this
external hard drive or memory stick in a safe place separate from your computer to prevent it being
stolen with your computer.
To change the default place where your backup files will be saved, go to Settings > Herds >
Default Folders for Files > Default Folder where Backup Files will be Saved. Please note: The default
place on the computer’s hard drive (C:\BenguFarm\Game\Backups\[Herd]) is NOT a safe place to save the
backup, since it will be lost if the computer is stolen or get damaged.
To make a backup, go to File > Backup and Restore. Under the heading Create a Backup, select the
type of data (Database(s), Saved Report Layouts, Photos & Documents) of which you want to make a
backup. Under the heading Make Backup To, select the location where you want to make the backup file.
Click to the right on Backup to make the backup. Use the Help function if necessary.
If you have more than one database in BenguFarm, remember to make a backup of each database.
To make a backup that includes everything (database(s), saved report layouts, photos & documents,
etc.), select Full System Backup (BFSysBackup folder).
From time to time you may delete old backup files not necessary anymore.
To set up a BenguFarm reminder to make backups on a regular basis, go to Settings > Herds >
Reminders.
To restore a backup:
o
Go to File > Backup and Restore.
o
If you have more than one database on BenguFarm, ensure you are in the correct database.
o
It is always a good idea to make a backup of the current data before backing up - just in case
something goes wrong.
o
To restore a database backup, the option Restore Full System Backup option (Select
BFSysBackup directory) under the heading Restore a Backup should NOT be selected. Click on
Browse, go to where the backup was saved, select the Database Backup_[date+time] file, click
Open and click Restore.
o
To restore a full system backup, select the option Restore Full System Backup (Select
BFSysBackup directory) under the heading Restore a Backup. Click on Browse, go to where the
backup was saved, select the BFSysBackup_[date+time] folder, click Open and click Restore.
Please note: If a full system backup is restored, ALL databases’ data will be overwritten.
To transfer data from one computer to a new or another computer:
o On the old computer:
▪
Insert a memory stick on which you are going to make a BenguFarm backup into the
computer.
▪
Open BenguFarm and go to File > Backup and Restore.
▪
Under Make a Backup, choose from What Type of Data do you want to make a Backup the
option Full System Backup (BFSysBackup folder).
▪
Click on Browse and select the memory stick drive and a folder where you want to make the
backup.
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Click on Backup. In the selected folder a sub-folder with the name BFSysBackup_[date+time]
in it will be created where all the applicable data, photos, etc. will be saved.
▪
Remove the memory stick with the backup from the computer.
o On the new computer:
▪
Insert the memory stick with the backup you’ve made into the new computer.
▪ Make sure BenguFarm is the same or newer version than on the old computer. (See the top of
the main screen for the version date).
▪ Open BenguFarm and select Restore a Backup from the Welcome window.
▪ Under the heading Restore a Backup, select the option Restore Full System Backup (select
BFSysBack... folder). Click on Browse and go to where the backup is on the memory stick and
select the BFSysBackup_[date+time] folder.
▪ Click Restore.
▪ To register BenguFarm on the new computer, call Naomi Havenga at 082 696 8306 and give
her the Computer Identification Code at the top left of the Registration screen and your
BenguFarm account name number (BPU___).
▪ All your BenguFarm data, photos, settings and own reports should now be on your new
computer.
Please note: All settings of all herds (where applicable) on the relevant database is included in the
backup of the database. Existing settings are therefore overwritten when a backup is restored.
▪

•

16.

Access to and synchronisation of data between computers:
BenguFarm can be installed on more than one computer with one license (i.e. no extra cost), provided
it is used only for the registered user’s herd(s). Follow the same steps for installation and registration on the
additional computer(s) as on the first computer.

VERY IMPORTANT!!!
The BenguFarm database is NOT "cloud" based, it is on the hard drive of the relevant computer
on which the program is installed. This means that data recording/editing can normally only be
done on one computer, unless the BenguFarm database is moved to a network server (“server”) - see the
network option below.
If you have installed BenguFarm on more than one computer, there are various options to
synchronise the data between computers and to give access to all the persons who need to work
on BenguFarm to the newest data on BenguFarm. These options are:
• Master computer option: With this option (which is presently used by most farmers), the owner should
decide on a master computer, i.e. the only computer on which new data will be entered and changed. A
backup of the BenguFarm database is then made on a regular basis on the master computer, shared (e.g.
via memory stick, e-mail, Teamviewer’s File Transfer or Dropbox) with the other users and each of them
then restore the backup on his/her computer. The other users therefore use the program only for queries
and reports, in other words they do not enter new data or change or delete data. Note: The first time a
backup is made on one computer and restored on another computer, a registration and access code will
be necessary to register that BenguFarm database on the new computer. After that backup and restore
can be done without the need for a registration and access code. [See paragraph 15 for backup and
restore functions].
• Network option: If the computers are linked to a network, e.g. a LAN, BenguFarm can be installed on
various computers, the BenguFarm database can be put on the server and each computer’s BenguFarm
linked to the database on the server. This way everyone has simultaneously access to the same live
database. Depending on some technical aspects, the program can in certain cases be a bit slower because
it needs to access the database via a network. Many of our clients make use of this option and, provided
the server is always on and all people have always access to the server, this option works well. For
instructions to set up BenguFarm for a server, contact your BenguFarm agent or Mr. Leslie Bergh at
leslie@benguelasoft.co.za or 0828012026.
• Multiple database option: This option works well where are for example two managers, each on a
separate farm, who are responsible for the data recording on BenguFarm of the herds/species on a
specific farm, e.g. Farm A and Farm B respectively. In such a case, separate databases for each
manager/farm can be set up and registered. On the owner’s computer two databases can be set up and
registered, one for Farm A and one for Farm B. The manager of Farm A can on a regular basis make a
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•

backup on his computer of Farm A’s database and it send (via e-mail, Dropbox, etc.) to the owner. The
owner can then restore the backup on his computer without effecting the data of Farm B. The same apply
for farm B. In this way the owner can have access to the newest data without working directly on the two
master databases.
TeamViewer option: TeamViewer software enables a person (through a Teamviewer ID number and
password which the other person should provide) to get access to the other person’s computer via the
internet. The Teamviewer option can work if the parties involved have relatively fast internet service. The
only problem with this is that the remote computer is not available for the person to work on while the
remote person is busy on it via TeamViewer.

NOTE:
You need to follow the steps up to paragraph 16 to ensure BenguFarm GAME is ready for further
use. In Part B of this manual, we will explain the recording and other functions which are
necessary for the basic use of BenguFarm GAME.
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PART B – BASIC FUNCTIONS:
17.

Groups – Calving Seasons, Camps, Management Groups, and Other:
Animal numbers categories:
BenguFarm automatically link animals to an Animal Numbers category (e.g., Heifer Calves, Young Heifers,

Breedable Heifers, Young Cows, Mature Cows, Old Cows) based on the animal's age, sex and (for female
animals) whether progeny is on record (cow) or not (heifer). For example, when a heifer's first calving is
recorded in BenguFarm, its category will automatically change from Breedable Heifers to Young Cows. Please
note that older cows without progeny on BenguFarm, regardless of age, are categorised as Breedable Heifers.
The animal numbers categories are displayed on, among other places, on the main screen > Herd Layout >
General > Category.
To see the criteria for the various animal numbers categories, go to Reports > Animal Lists and
Numbers > Animal Numbers and Values. At the top left of the screen at Select Calculation Method, click the
setup shortcut button (red notebook). The Default Cattle Numbers method cannot be changed. If the Default
Cattle Numbers method does not meet your needs, you can set up your own method by clicking New or Copy.
We recommend selecting the Copy option, only change it as needed and then save it with a name. Please
discuss your own criteria with your BenguFarm GAME agent to ensure that the criteria are set up so that
certain animals are not excluded from the count. Tip: To record average tax and market values for the
different categories of animals, complete the Market Value and Tax Value columns and Save. To select a
different calculation method as the default method for the particular herd, go to Settings > Herds > Reminders
> Default Animal Numbers Calculation Method.
To create an animal numbers and values report which will show the number of animals in the herd per
category, go to Reports > Animal Lists and Numbers > Animal Numbers and Values. There are two options for
the report: The Category View lists the number of animals per category with values (if set up) and livestock
units (LSU). The Camp View lists the number of animals per category per camp.

Own Set Up Groups:
In BenguFarm GAME different type of groups can be set up and animals linked to it. The different types of
groups are called Categories, e.g. Calving Seasons, Camps, Management Groups, etc. Under each category,
the relevant groups are set up. Under Calving Seasons, for example, a calving season "Spring 2019" can be set
up to link all calves born in that season to it.
Groups are used to select a group of animals easily, quickly and accurately for recording data (e.g. to record
results of pregnancy tests for all animals in Camp 1) or for inclusion in a report (e.g. to create a weighing list
for all calves born in the Spring 2019 season), to have an inventory to check if all animals are in a camp or
group, to know in which camp or group to look for an animal, to record feed and/or lick usage per camp and
to calculate pasture utilization per camp.
Please note:
o Animals cannot be linked to a category; they should be linked to groups of the applicable category.
o Groups in different categories are independent of each other. An animal can, for example, be linked to
a certain calving season, camp and management group.

Calving Season Groups:
•
•

Calving seasons are used to indicate in which year and season the animal was born. Calving seasons are
also specified when entering matings (if applicable). Mating and calving seasons are normally NOT
used by game breeders. If you are not using it, you can ignore this setting.
If you do make use of breeding and calving seasons, go to Settings > Calving Seasons and click on the
“+” (right bottom corner of the window) to create a new season record. It is recommended that you use
the year and first letter of the season for the calving season code, e.g.:
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Calving Season
Herd

In
Use
√

ALL

Code

Name

2017S

Calves born
2017 Spring

Mating Season
Begin
Mating
15 Nov 2016

Calvings

End Mating

Start

End

15 Feb 2017

calculated

calculated

After the new calving season has been saved, select the Current Calving Season in the yellow area of the
window and click on Save.

Camp Groups:
•

Camps are used to link animals in BenguFarm to keep record of which animals are or were in which
camps on a specific date. It can then be used for stock take. It is also used to calculate the pasture
utilization per camp and to record feed and/or lick usage per camp.
To set up a new camp, go to Settings > Camps and click on the “+” (right bottom corner of the
window), for example:

•
Herd

In
Use

Device

Code

Name

Scale ID

Type of
grazing

Size
(ha)

√
√

√
√

FC1
FC2

Fairview Camp 1
Fairview Camp 2

n.a.
n.a.

Sour bushveld
Sour bushveld

25
32

ALL
ALL

Carrying
Capacity
(ha/LSU)
5
6

Total
LSUs
5.0
5.3

Please note:
o The setup of camp sizes and carrying capacity per camp is optional, but it is important to get the full
benefit of the Pasture Utilisation per Camp report (see the paragraph below for more info).
o The category Camps on Farm is set up to allow an animal to be in only ONE camp at a time. If an
animal is moved from one camp to another, it is automatically removed from the previous camp.
o Also create a Boma “camp” and, if applicable, also an Open Farm “camp” to enable you to move
animals to the boma or the open farm.
o Do not give camps the name of the species that runs in the particular camp, because it creates
confusion when a species is moved to a different species’ camp. Give ideally camp numbers. The
species running in a camp may be added in brackets after the camp name, e.g. Camp 1 (Buffalo).

Management Groups:
•

•
•

Management groups are used to link animals that are managed together, regardless of in which camp(s)
the group is to a group in BenguFarm, e.g. Young Heifers, Pregnant Heifers, First Calf Cows, Mature Cows.
Please note: The actual management groups on the farm dictate how the management groups in
BenguFarm should be set up, not the other way around.
We recommend that management groups be set up that an animal can only be in one
management group. To do this, go to Settings > Groups and Camps > Select Category > Management
Groups > Add/Edit/Remove Categories and select the option Only in One Group.
Tip: At Settings > Herds > Other > Default Group Category, the most often used groups category can be
selected.

Cull and Sale Groups:
•

•

Cull and Sale Groups are used to link animals to be culled or sold in BenguFarm, for example cows for
possible culling, weaners to sell and production sale animals. These groups allow you to choose animals to
be culled or sold, irrespective in which camps or management groups these animals are in. Animals linked
to a cull or sale group therefore remain in their respective camp or management group until such time as
they are sold.
The default setting of the category Cull and Sale Groups is that an animal can be in more than one cull or
sale group at a time. To change it so that an animal can only be in one cull or sale group at a time, go to
Settings > Groups and Camps > Select Category > Add/Edit/Delete Categories > check the Only in One
Group box next to the Cull and Sale Groups > Save > Exit.
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Link or move animals to a camp or group:
•

•

•
•
•
•
•

•

•

To link animals to a group (e.g. a camp or management group) or to move animals between
groups or camps:
o Go to Other Data > Move Animals to another Camp or Group. Use the Help function if necessary;
OR
o Animals can also be linked or moved to camps or groups on the main window’s Herd View, most
recording windows and some report windows by selecting the relevant animals in the S column
and clicking on Link Animals to Group. This feature has several options, e.g. to move selected
cows' calves to the same or another camp as the dams.
o Animals can also be linked to a camp on the Add Animals Wizard, Add and Edit Animals (Single
Animal Layout) and Edit Animals (Table Layout) screens.
To link animals which are in a management group also to a camp (or vice versa):
o Go to Other Data> Move Animals to Another Camp or Group. Select the camp to move the animals
to the right at the top of the screen as the active group. In the middle of the screen (under the
heading Add / Remove Animals by Group / Camp), by Category, select Management Groups. At
Group / Camp, select the relevant management group. Click on the black arrow on the right of the
Group / Camp to place the animals in the relevant management group in the camp concerned.
Use the Help function if necessary.
o Go to the Herd Layout on the main window and at the group filter (to the right of the Female
filter), select the relevant existing group/camp. Select the animals in the S column and click Link
Animals to Group. Then link them to the desired group or camp.
To edit existing camp movements of an animal, go to Animals > Add and Edit Animals (Single
Animal Layout) > General. At the Camps field, click the Edit Camp Movement History button.
To create a report of animals per camp or group, go to Reports > Camps and Herds > Animals per
Camp or Group. Note: The animals that are not assigned to a camp are listed in a "camp" with code
“[none]”.
To create a report of animal movements between camps, go to Reports > Camps and Herds >
Camp Movements.
To create a report with the number of animals per species per camp, go to Reports > Camps and
Herds > Camp Species Composition. Tip: To see which animals are included in a specific number, click on
the specific number.
To create a report of the pasture utilisation of camps for a certain period, go to Reports >
Camps and Herds > Pasture Utilisation per Camp. This report will only be available if the camps are set up
with at least the camp sizes. Tip: Click the Calculate information button at the bottom right of the screen
to see how the calculations are done. Please note:
o This report uses the camp movement history in BenguFarm. It is therefore critical that this data is
available for the period for which the report is created.
o To get the full benefit of this report, specifically the percentage utilisation of the various camps, it
is important to set up camp sizes and carrying capacity (LSUs/ha) per camp at Settings > Camps.
o Animals that have been sold or died should be recorded with the date, etc. at Sales, Deaths and
Culls (i.e. their status should not be simply changed to Non-active) to ensure that the period in the
last camp is calculated correctly.
o To see how the number of LSUs is calculated for different animal categories, go to Settings >
Herds > Reminders > Default Animal Numbers Calculation Method and click the settings button.
o The number of LSUs is calculated according to the category in which the animal concerned was at
the time when the animal was in the camp.
To view the camp data of an animal on the main window, go on the Animal View to the General
view window and scroll down to the camp information fields or go on the Herd View to the Camp section.
Tip: Filter the relevant camp at the Group Filter to only see the animals of a specific camp on the Herd
View.
To view other groups (e.g. management groups) in which an animal is on the main screen, go
to the Animal View to the General view window and scroll down to the My Groups field or go on the Herd
View to the General section. If there is no column for Management Groups on the Herd View, go to
Display Options, select the Show Groups of Category option, select Management Groups, and click Save
Options as Herd Default.
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Filter Groups:
•

18.

A filter group is a group of animals as selected by a certain set of criteria. These criteria can be specified
and saved in the My Animal Data report [See Reports > My Reports > Animal Data > Select Animals
(Criteria)]. You can for example setup criteria to list all active female animals born in a certain year and
that did not calve yet. These criteria can then be saved for later use. Animals can be selected via saved
filter groups on the Choose Animals window, on the main window > Herd Layout > Group Filter as well as
in the My Animal Data reports. Please note: It is important to note that a filter group is thus not a
specific selection of animals stored somewhere in the database. The animals in the group are determined
by the stored criteria and the applicable field values of the animals in the herd at the point in time when
the filter group is selected.

Sending and receiving of electronic data:
18.1

Synchronise data with BenguFarm MOBILE for Game:
BenguFarm MOBILE for Game is an Android application (app). BenguFarm MOBILE enables game
farmers to capture and also look up basic animal data of new animals/calves and all data captured at
darting on an Android smartphone or tablet. Darting data includes horn measurements, photos, camp
movements, vaccinations & supplements, microchip implants, pregnancy tests, fertility tests, teeth
condition, internal parasites, diseases & injuries, treatments, veterinary notes and weights.
The information recorded on BenguFarm-MOBILE can be synchronised with the BenguFarm database
on the PC/laptop(s). Synchronisation of data can be done via Wi-Fi or Internet connection, depending
on which method is available and the method preferred by the user.
See the BenguFarm MOBILE for Game manual for instructions to synchronise data between
BenguFarm MOBILE and BenguFarm GAME.

18.2

19.

Sending and receiving Logix data:
See Appendix B.

Matings and inbreeding calculation for planned matings:
•
•

•
•
•
•

•

The recording of matings is only applicable if breeding seasons are practiced. If breeding seasons are
not used and matings are not recorded, pregnancies can be recorded on the Darting Data
window [Other Data > Darting Data > Pregnancy].
If breeding seasons are used, we recommend that you record the natural matings and/or artificial
inseminations (AIs) in BenguFarm GAME as soon as the bulls are put with the cows and/or the AIs are
done. This has various advantages, inter alia that lists to record pregnancies can be created from
BenguFarm GAME and it is also much easier to record calvings in BenguFarm GAME, because the possible
matings/sires are then available.
If breeding seasons are not used and matings are not recorded, pregnancies can be recorded
on the Darting Data window [Other Data > Darting Data > Pregnancy].
To create a list of breedable heifers and cows (if applicable), go to Reports > Matings, Pregnancies
and Calvings > Breedable Heifers and Cows (recording list). Tip: Filter the relevant camp at the Group
Filter to only see the animals of a specific camp on the Herd View.
To create a list on which specific, observed matings can be recorded (if applicable), go to Reports
> Matings, Pregnancies and Calvings > Matings (recording list).
To calculate the inbreeding percentages of progeny for possible matings, go to Reproduction >
Inbreeding Calculation for Planned Matings. Note: Inbreeding percentages in red are higher than the
value set (default = 6.25%) for “Warn if the Inbreeding percentage is higher than” at Settings > Herds >
Mating, Pregnancy and Calving and such matings should be avoided. Use the Help function if necessary.
Tips:
o
Click on the Common Inbreeding % button at the bottom of the screen for the inbreeding
percentages of some common matings.
o
When the inbreeding percentage of possible matings are calculated and there is inbreeding, go on
the Animal Layout of the main window to the Pedigree view window of the concerned parents to
see which animal(s) is the common ancestor.
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Matings can be recorded directly on this screen by selecting the relevant bull(s) and cow
combinations and record the matings for the selected combinations at the bottom of the screen.
o
For an article on the dangers of inbreeding, contact Mr. Leslie Bergh at
leslie@benguelasoft.co.za or 082 801 2026.
o
To create a pedigree report, go to Reports > Animal, Pedigree and Progeny > Pedigree.
Common ancestors (which cause inbreeding) will be displayed on a red background on the
pedigree report for easy identification.
o
To see which animals are related to a specific animal (e.g. a bull), go to Reports > Animal,
Pedigree and Progeny > Related Animals.
•
Before recording matings in BenguFarm GAME:
o
Ensure that all the cows, heifers and breeding bulls (including AI bulls) are on record in
BenguFarm GAME.
o
To ensure that breeding bulls (herd sires) are displayed on top of the list of bulls on the Natural
Matings and AI windows, go to the Add and Edit Animals (Single Animal Layout) window, find the
applicable bull and mark (highlight) the bull. Make a tick mark in the field "Breeding/AI Bull"
and click Save. This will also ensure that active breeding bulls are listed separately in the
“Breeding Bulls” category on the Animal Numbers report (Reports > Animal Lists & Numbers
>Animal Numbers).
o
If a bull is used in more than one herd that is on the same database in BenguFarm GAME, go
to Animals > Add and Edit Animals (Single Animal Layout) > General Data and mark the field
Visible for Reproduction in All Herds. And Save. A bull marked as such will be visible on the
Matings screen in the list of bulls to select as the bull and on the on the Calving screen to select
as the sire of a calf. However, the bull will not be listed in the other herd as an active bull in the
herd list.
o
Ensure that the applicable calving season has been created. [Refer the Settings section above
to create a new calving season].
o
If animals are linked to camp groups, remember to move the animals of the new breeding
groups to the relevant camp in BenguFarm before the new matings are recorded in BenguFarm
because then the camp group can be used to select the animals for the registration of coverings.
If there are also calves in the camp, check at Existing Groups also Birth Date and choose the
dates of birth to exclude the calves.
• To record (or edit/delete) matings, go to Reproduction > Matings and choosing the applicable mating
method (e.g. Natural Mating). Use the Help function if necessary.
• If multi-sire mating groups are used, choose in the Bull field the default “?MULTISIRE?” record listed
directly under the breeding bulls.
o
Please note: Do NOT create a "Multisire" animal record yourself, as BenguFarm will consider it
as a real bull and then all animals with "Multisire" as sire will be related.
o
To choose the bulls in the specific multi-sire bull group, tick the box next to Multi Sires and then
click on the “+” to select the applicable bulls.
o
To see which bulls are the possible sire of an animal, go on the main window to the Animal
View > Birth view window > Mating Bull(s).
•
If a bull cannot continue mating during the mating season (sick/injured/dead):
o
Change the Bull Out date on the existing mating records [Natural Matings > Load Existing
Records];
o
If the bull died, remove the Breeding/AI Bull mark from the bull's record and record the death on
the Sales, Deaths and Culls screen;
o
If the bull is replaced with another bull for the remainder of the mating season, record new
mating records for the replacement bull at Natural Matings.
• To create a report of existing matings, go to Reports > Matings, Pregnancies and Calvings > Existing
Matings (Mating Lists). See Appendix C for expected calving date calculation.
• To view the last mating data of an animal on the main window, go on the Animal View to the
Last Mating view window or on the Herd View to the Previous and Last Mating sections. Please note:
Only existing matings, in other words matings of which the cow has not yet calved, are displayed here. To
view all the mating and pregnancy data of an animal on the main window, go on the Animal View to the
Mating and Pregnancy History view window.
o
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20.

Pregnancy tests:
•
•
•
•

•
•

21.

Please note: Pregnancy test results can be recorded without mating recordings. To do this, go
to Other Data > Darting Data > Pregnancy.
To create a list to record the pregnancy test results, go to Reports > Matings, Pregnancies and
Calvings > Cows & Heifers for Pregnancy Test (recording list).
To record (or edit/delete) pregnancy test results, go to Reproduction > Pregnancy Test. Use the Help
function if necessary.
To create a report of matings and pregnancies, go to Reports > Matings, Pregnancies and Calvings
> Matings and Pregnancies. Please note: If the Existing Matings option is selected, only mating and
pregnancy records of heifers and cows which have not yet calved, will be listed. If only the option
Pregnant and/or Not Pregnant (i.e. Existing Matings is not selected) is selected, mating and pregnancy
records of all relevant heifers and cows will be listed, regardless of whether they have calved or have not
yet calved. See Appendix C for expected calving date calculation.
To create a report with a summary of matings and pregnancies per bull and/or season (if
applicable), go to Reports > Matings, Pregnancies and Calvings > Mating Summary per Bull and/or
Season.
To view the last mating and pregnancy data of an animal on the main window, go on the Animal
View to the Last Mating view window or on the Herd View to the Pregnancy section. On the Herd View
expected calving dates of cows that should have calved more than 14 days ago are highlighted in red. To
view all the mating and pregnancy data of an animal on the main window, go on the Animal View to the
Matings and Pregnancy History view window.

Calvings/calves born (including abortions, still born calves, etc.):
• To create a report of heifers and cows near calving, go to Reports > Matings, Pregnancies and
Calvings > Heifers and Cows near Calving (recording list). The various options used to calculate
expected calving dates of heifers and cows are explained in detail in Appendix C.
• Before you record calvings, ensure that you have recorded the applicable matings and pregnancy test
results (if applicable) in BenguFarm GAME (refer paragraphs 19 and 20). Please note: The recording
of matings apply only where breeding seasons are used. See below for how to choose the sire where
no matings were recorded.
• To record (or edit/delete) calvings (and calves), go to Reproduction > Calvings.
o Choose the applicable cow/heifer, choose the calving date, choose the sire and complete and/or
change the rest of the details, where applicable. Use the Help function if necessary.
o Please note:
▪ Most of the fields will be filled by default with the applicable data as retrieved from the
Settings you have done in BenguFarm GAME (refer paragraph 5). The calf’s sex, birth date,
birth weight and the cow’s weight at calving (if recorded) should be completed by you.
▪ If a mating(s) was recorded for the applicable cow which could cause a calving on the
calving date (according to the normal pregnancy period), the most probable bull's number
(based on the expected calving date) will automatically be displayed as the sire of the calf. If
there are two matings listed as possible matings, the sire is not certain.
▪ If "New Mating" is displayed in the Bull (Mating) field after the calving date has been
entered, it means that there is no mating on record for the cow which could cause a calving
on that calving date. In such a case the bull should be selected at the Mating Data to the right
of your window, in which case a default mating record will be created.
▪ If matings were not recorded (because no mating seasons were practiced), the relevant
animals are linked to camps and camp movement history is available, you can determine the
possible sire of a calf from the camp movement history. On the Mating Data area of
the calving window, click on the button “Bulls in the Same Camp as Cow at Mating” to the far
right of the Bull field. This will bring up a window displaying the bull(s) that were in the same
camp as the cow at the stage the cow should have become pregnant. You can select this bull
(or bulls as multiple sires) as the sire of the calf.
▪ To change a calf's sire which was recorded at birth as unknown [?UNKNOWN?] OR
recorded as multi-sire [?MULTISIRE?] OR recorded incorrectly, go to the Add and Edit Animals
(single animal layout) and select the appropriate calf. At the Mating (not Sire) field, select the
appropriate mating (bull) or New Mating from the list. A Mating Details window will open (on a
light blue background). Select the correct bull (sire) here, click Save and Exit.

25

If the sex of a calf is uncertain or unknown at the time of recording the calving, choose
either male or female and mark the "?" (sex Uncertain or Unknown) field to the right of the
animal sex field. The IDnr of animals with sex uncertain or unknown will be displayed with a
red background colour in the animal list on the main window. When the sex is later confirmed,
go to Animals > Add and Edit Animals (Single Animal Layout), remove the tick in the Sex
Uncertain field and, if necessary, change the sex and Save.
▪ If the default sequence number of the calf is need to be changed, change it in the
Sequence Number field.
▪ Abortions, stillborn calves and calves that died shortly after birth should be recorded
to change the pregnancy status of the applicable cows and to make their reproduction records
complete. Select the appropriate option (e.g. Still born) in the field Calf Status (at birth). A
fictitious number can be assigned to such calves, e.g. ABC2000D1 (D for Dead) or
ABC209001 (sequence number outside the normal range) for the first dead-born calf in 2020.
▪ To correct the pregnancy status of cows that were recorded as pregnant at
pregnancy test, but did not calf, go to the Pregnancy Test screen, click Load Existing
Tests, select the applicable cows, remove the tick in the Pregnant column, change the period
to 0 (zero) and Save.
▪ If a new calf is seen, but it cannot be determined which cow it was that calved, the
calving cannot be recorded on the Calving window, because the cow cannot be selected. To
record such a calf's birth in BenguFarm, go to Animals > Add and Edit Animals (Single Animal
Layout), click "+ Add", complete the necessary birth data and Save. When the mother is later
identified, go back to this window, select the calf from the list of animals, select the mother in
Dam field and Save.
▪ If a cow has calved, but it cannot be determined which calf is that cow’s calf OR if a
calf was not numbered at birth, record the calving normally on BenguFarm with the next
available sequence number for the calf but add a D at the end of the calf's number (e.g. 151D) to indicate that this is only a dummy number. When the calves are numbered (with an
ear tag) and a specific calf can be positively linked to the cow (e.g. seen that a specific calf is
suckling the applicable cow), go in BenguFarm to Reproduction > Calving and select the
particular cow. Next to the cow's number is a field where an "N" will be. Open the list and
select the appropriate calving date (with the dummy number calf). The relevant calving will be
displayed op the Calving window. At the calf's Sequence number, change the dummy calf
number (e.g. 1D) to the correct calf number (e.g. 8) and click Save.
▪ To record twins, ensure that you choose Twins in the field # Calves (Birth Status).
BenguFarm GAME will automatically create two tabs with calf numbers at the top of the grey
area (calf information) of the window. Click on the first calf’s number and complete the calf’s
details. Then click on the second calf’s number and do the same.
▪ To record that a calf is reared by a foster dam or orphaned, go on the Calving screen to
the Foster Dam field (bottom left). It can also be recorded by going to Animal > Add and Edit
Animals (single animal layout) > General > Foster Dam. In the list there is also an ORPHAN
PENS option that can be used for calves raised as orphans.
▪ To edit an existing calving/birth data, go to the Calving window, choose the applicable
cow, click on the “N” next to her number and choose the calving you want to change.
▪ To delete an existing calving/calf, go to Animals> Add and Edit Animals (Single Animal
Layout). Select the calf in question and click Delete.
To create a report of heifers and cows that have calved/not calved yet, go to Reports > Matings,
Pregnancies and Calvings > Heifers and Cows that Calved/Not Calved Yet (recording list). See the notes at
Report Interpretation for which animals are listed for the various scenarios.
To create a report with a summary of matings, pregnancies and calvings per bull and/or
season, go to Reports > Matings, Pregnancies and Calvings > Mating Summary per Bull and/or Season.
To create a report of cows which performed poorly according to certain reproduction and
pregnancy minimum standards (that you can set yourself), go to Reports > Inspections and Selections
> Reproduction and Pregnancy Selection.
To create a report of calves born in a certain period (e.g. calving season or year), go to Reports >
Matings, Pregnancies & Calvings > Births. Tip: Remember to also select the non-active filter to include
calves recorded as abortions, stillborn, died at/shortly after birth. This is important to get the correct
summary of percentage calves born alive, stillborn, etc.
▪

•
•
•
•
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22.

To view the birth data of an animal on the main window, go on the Animal View to the Birth view
window or go on the Herd View to the Birth section.
To view the reproduction and progeny averages data of an animal on the main window, go on
the Animal View to the Reproduction and Progeny Av. view window or go on the Herd View to the
Reproduction section.
The various reproduction calculations in BenguFarm GAME are explained in Appendix C.

Parentage verification and other DNA services:
•

•
•

•

•
•
•

•
•

•
•
•

To create a DNA service request form that should accompany the applicable animals’ biological
samples to the DNA laboratory, go in BenguFarm GAME to Data Send/Import > Send > DNA Profiling
Service Forms and select the applicable laboratory you use. Use the Help function if necessary.
Please note:
o If you want to keep a record of which animals’ DNA were send for analysis, mark at the bottom
right of the window "Yes, keep record of sent DNA samples specified below".
o To ensure the customer's details are completed correctly on the service request form, make sure
all relevant fields (Owner, Farm Name, Invoices Made Out To, VAT No. and Postal Address) is
completed at Setting > Herds > General.
o NRF/NZG DNA Services: The form includes a reference number that should be used with payment.
You will have to contact NZG to get a valid reference number as they use the form also as an
invoice and you must use the reference number with the payment.
To print labels for the marking of the envelopes in which biological samples (e.g. tail hairs) of
animals are placed for submission to a DNA laboratory, go to Data Send/Import > Send > DNA Profiling
Service Forms > Print Biological Sample Labels.
To create a report of DNA samples sent for analysis, go to Reports > Administration > Log of DNA
Samples Sent. If an animal's DNA Number does not appear on the report, it indicates that the results of
the animal concerned have not yet been received and/or not yet imported/recorded in BenguFarm.
When the DNA report is received from the DNA laboratory, the applicable animal’s DNA
numbers, correct parentage and bloodline (where applicable) can be recorded and certified at
Animals > DNA Verified Parentage and Bloodlines. Please note: The DNA numbers must be completed
before the certification field can be checked. You should also check the certification declaration at the
bottom of the window before the data can be saved. Tip: To record the bloodline percentages,
obtained from the nuclear DNA analysis, click on the puzzle icon (Bloodline Composition) next to Analysis
Type. This icon will only be displayed if nuclear DNA was selected at Analysis Type.
Please note: The ZooOmics DNA lab will also send you a CSV file which you can import directly into
BenguFarm, saving you the trouble to record the parentage and/or bloodline results by hand in
BenguFarm. To import this CSV file, go to Data Send/Import > Import > ZooOmics DNA Results.
Certified parents will be displayed with the DNA icon on the main window in the Pedigree view window.
On the Add and Edit Animals window [Animals > Add and Edit Animals] the parents are displayed in the
same way as certified. If the parents are changed here, the certification expires and the certification for
the newly selected parents should be done again on the certification window. Certified parents will also be
displayed with the DNA icon on the Animal Summary report [Reports > Animal, Pedigree and Progeny
Summary > Animal Summary, Sale Catalogue report [Reports > Purchases, Auctions and Sales > Sale
Catalogue] and Pedigree report [Reports > Animal, Pedigree and Progeny Summary > Pedigree].
To view the DNA number of an animal on the main window, go on the Animal View to the General
view window and scroll down to the DNA Number field or go on the Herd View to the Identification
section.
To create a report indicating which animals' parents are certified in BenguFarm, go to Reports
> My Reports > Animal Data. Click Choose Animals (Criteria) to choose the animals. Then click on Report
Columns (Layout). Under the General section, select Sire DNA Verified and Dam DNA Verified. Click View
Report to see what the report will look like.
To create a report with the DNA Verified Parentage and Bloodlines data, go to Reports > Animal,
Pedigree and Progeny > Animal Summary and make sure the option Print DNA Verified Information is
selected.
To view the bloodline of an animal on the main window, go to the General view window and scroll
down to the bloodline information fields.
Tip: Save the animal's DNA certificate as a document on BenguFarm - see paragraph 23 below.
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23.

Photos and documents:
•

•
•
•

•

24.

To import (or edit/delete) animal photos and documents (e.g. purchase invoice, DNA certificate,
fertility/pregnancy certificate, sale invoice), go to Other Data > Photos and Documents. Use the Help
function if necessary.
Please note: Photos in BMP, GIF, JPEG PNG and TIFF format and documents in any format can be
imported. A video can also be imported and viewed as a document.
To view an animal’s photos on the main window, go on the Animal View to the Photos view window.
To view an animal’s documents (including videos) on the main window, go on the Animal View
to the Documents view window, select the document and click on Display Document.
Photos of an animal and/or its parents can be displayed on the Animal Summary, Sale
Catalogue and Pedigree reports. A maximum of 4 photos can be included in the Animal Summary and
Sale Catalogue reports.
o The photos of an animal will only appear if the relevant photos were selected on the Photos and
Documents window in the Reports column to be displayed on reports. Please note that a
maximum of four photos can be selected for inclusion in a particular report.
o The photos of an animal's parents to be used will be the applicable parent’s primary (default)
photo, if marked for display at the applicable animal (parent) in reports, or else the latest nonprimary photo (by picture date) which is marked for reports will be used.
To display an animal, its pedigree and progeny's pictures on one screen, go on the main screen
to the Animal View > Photos view screen and click below the animal's photo on the Pedigree and Progeny
Photo Browser button.

Estimate horn measurements from a photo:
An animal’s horns can be "measured" or estimated from a photo with the Photo Tape function in
BenguFarm-GAME. With this function users can, without the need to dart the animal, get an accurate
estimate of an animal’s horn measurements. These estimated measurements can be used to “screen” animals
and then select only promising animals for actual measurement. See the instructions below to use the Photo
Tape function and for important aspects to increase the accuracy of horn length estimates.
1. Go to Performance Testing > Photo Tape.
2. There are several aspects that play a role in the accuracy of the "measurement". We therefore prefer to
refer to "estimate" instead of "measurement", as it is not an exact science and the measurements that are
obtained in this way is not necessarily 100% correct, depending on certain technical aspects.
3. At the top of window (on the green background) the most important issues related to the estimation of
measurements from photographs are highlighted.
4. Use the step-by-step Help function at the top right of the window to learn how to use the window. In
the Help function's text aspects that could influence the accuracy of estimation are also referred to.

Important aspects that affect the accuracy of estimates:
1. The larger the picture can be displayed, the better.
1.1. If possible, use a "big computer screen (e. g. 27") instead of a small (e.g. 14 ") screen when this
function is used.
1.2. Zoom the photo as large as possible so that the horn that should be measured just fit on the window.
The picture can be moved horizontally and vertically on the window so that only the horns are
displayed.
2. There must be an object (e.g. an ear tag) on the photo that can be used as a scale object. The photo
must first be calibrated using the scale object before measurements can be estimated on the photo.
3. For calibration you must beforehand know exactly how big the scale object (e.g. an ear tag with a circle
on that 67mm wide). Tip: Record the ear tag size in Notes on the animal's record in question for future
use.
4. The scale object (e.g. ear tag) must be photographed straight from the front, i.e. at an angle of 90° with
respect to the camera.
4.1. Ear tags with a circle on it is available (e.g. from RFID Experts). Depending on the size of the tag, the
circle has a certain diameter (e.g. 67mm). The diameter of the circle can be used to calibrate the
picture. The advantage of these tags is that, as long as the circle is turned towards the camera with
at least one level at an angle of 90° with respect to the camera, there will be at least one level where
the diameter can be calibrated correctly. If the tag is tilted for example horizontally when the photo
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5.
6.
7.

8.

25.

was taken, the vertical diameter of the circle can be used to calibrate the picture. If the tag is tilted
vertically when the picture was taken, the horizontal diameter of the circle can be used.
The horn that should be measured must be the same distance as the scale object (e.g. ear tag) from the
camera. The further or nearer the scale object is to the camera in relation to the scale object, the less
accurate the calibration of the photo will be.
As with the scale object, the horn that should be measured must be at a 90° angle in respect of the
camera. (For sables, the horn that should be measured must be photographed from the side. For buffalo
horns’ spread, the buffalo must face straight to the camera).
It is extremely important to mark the scale object (e.g. an ear tag) as accurate as possible with the blue
line. An error that is made here, will pro rata affect the assessment of the horn length. Zoom in as much
as possible on the photo so that the tag which is to be measured only just fit on the screen to ensure that
the ear tag can be measured as accurate as possible.
As with the scale object (ear tag), it is essential to mark the horn as accurately as possible (with the red
line). Where it is a curved line (e.g. sable horns), the curve should be followed as accurately as possible.
Tip: If you make a mistake with the "measurement" of the horns, right click on the red line to undo.

Horn measurements and other data collected at darting of animals:
•

•

•

•
•

•
•

To create a list for recording animals’ horn measurements and other traits at darting, go to
Reports > Weights, Measurements, Performance Testing and Breeding Values > Trait Lists (recording list).
At Select Items to Print, select the traits you want to record and with the right arrow add it to the Items to
Print on Report.
To create a list for recording vaccinations, dosings, supplements and procedures at darting,
go to Reports > Diseases – Prevention and Treatments > Vaccinations, Dosings, Supplements and
Procedures (recording list). At Select Items to Print, select the vaccinations/dosings/supplements/
procedures you want to record and add it to the Items to Print on Report with the arrow pointing to the
right.
To record (or edit/delete) various data (including horn measurements) collected at the darting
(tranquilising) of an animal on one window, go to Other Data > Darting Data.
o Select a date (at Enter Date) OR Add/Select a Vet Visit. To create a new Vet Visit record, click on
Add / Edit next to the Select a Vet Visit field. Click on Add Vet Visit (top right of window),
complete the applicable data and Save.
o Click on the General tab to record horn measurements, photos, camp movements, pregnancies
(females), fertility data (bulls), veterinary notes and internal parasites (egg counts).
o Tip: Horn measurements must be recorded with decimals. See the button "i Fractions to
Decimals" at the bottom of the screen for converting fractions to decimals.
o See paragraph 24 for instructions to use the Photo Tape function and for important aspects to
increase the accuracy of horn length estimates.
o Click on the Vaccinations, Dosing and Supplements tab to record vaccinations, dosings and
supplements (e.g. vitamin injection) data.
o Click on the Diseases/Injuries and Treatments tab to record diseases, injuries and treatments.
o Click on the Other tab to record a microchip implant and DNA sample collection, weights and other
procedures (e.g. Hooves trimmed)
To edit or delete a single animal’s existing Darting Data, go to Other Data > Darting Data, select
the relevant animal and at Saved Dates for This Animal, select the applicable date. The data will now be
displayed. It can, if necessary, be changed, added or deleted and saved.
To edit or delete the measurement date of an animal(s) or to edit or delete various animals’
horn or other measurements, go to Performance Testing > Horn and Other Measurements. Click at the
top right on Load Existing Records and select the appropriate measurements date.
To create a report of other trait measurements/scores, go to Reports > Weights, Measurements,
Performance Testing and Breeding Values > Traits Report.
To view the horn measurements of an animal on the main window’s Animal View, go to the
Horn Measurements view window.
o The growth per month since birth is displayed in round brackets after the measurement.
o To display the horn growth between measurements instead of since birth, go to View >
Horn Measurements View Screen Options and select Show Growth Between Measurements. The
horn growth between measurements is displayed in square brackets after the measurement.
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To choose which traits to be displayed on the graph, click on the hammer and wrench
button left on top of the graph.
To view the last horn measurements of animals on the main window’s Herd View, go to the
Last Horn Measurements section.
Other trait measurements/scores can be viewed on the Animal View of the main window on the Trait
Measurements view window.
To create a report to compare animals’ horn growth by means of the horn growth index, see
paragraph 25.
To create an animal summary report with various types of data (including general information,
photos, pedigree with DNA certified parent symbols, progeny, horn and other measurements, microchip
implants, internal parasites, vaccinations, dosings and supplements, illness/injuries and treatments), go to
Reports > Animal, Pedigree and Progeny Summary > Animal Summary.
o To include photos of the animal and/or its parents in the Animal Summary (and Sale Catalogue)
report, see paragraph 23 above.
o The farming enterprise’s logo can be displayed on top of the report. The logo should be in a
picture format, e.g. jpeg, i.e. not in pdf format.
o

•
•
•
•

Please note:
• Horn measurements and other traits (also scores) can also be recorded at Performance Testing >
Horn Measurements or Weights and Recordings not linked to a Test > Traits. Use the Help function if
necessary.
• See Appendix C for the various reproduction and horn measurement calculations in BenguFarm
GAME.

26.

Selection:
•

•
•
•
•
•

27.

To create a report of horn measurements to compare animals’ horn growth by means of the
horn growth index, go to Reports > Weights, Measurements, Performance Testing and Breeding Values
> Horn Measurements Evaluation. Note: See Appendix C, section Horn Measurements for the
interpretation and use of horn growth calculations and indexes.
Please note: It is very important to select animals to be included in the report in such a way that
environmental effects that can influence horn growth (e.g. age and nutrition of animals), are eliminated as
far as possible. Male and female animals are automatically evaluated in separate groups. Tip: At Report
Options the relative importance of traits can be selected for the calculation of the average index (last
column on the report).
For a description of the various reproduction and horn measurement calculations in
BenguFarm-GAME, see Appendix C. See the Horn Measurements section for the interpretation of the
calculations in the horn measurements evaluation report.
To create a report of cows which performed poorly according to self-chosen reproduction and
pregnancy minimum standards, go to Reports > Inspections and Selections > Reproduction and
Pregnancy Selection. See Appendix C for the interpretation and use of calculated values in BenguFarm.
To create a report of animals which performed poorly according to self-chosen standards (that you
can decide yourself), go to Reports > Inspections and Selections > Breeding Herd Selection. [Not available
yet].
To create a progeny report of a cow or bull, go to Reports > Animal, Pedigree and Progeny >
Progeny Summary. [Not available yet].
To highlight certain animal data (e.g. cows with an average inter-calving period of more than 400
days on the main screen’s Herd View as well as setting up rank values for the selected criteria (the
total rank value to be displayed in the General section in the Rank column), click View Options at the
bottom of the main screen’s Herd View and then click at the top of the View Options screen on Setup Herd
Layout Highlighting (button with small squares with different colours). Use the Help function if necessary.
See paragraph 5 for how to create a report with selected columns from the main screen's Herd View.

Sales, hunts, deaths and culls:
•

To create a sale catalogue report, which can be useful in marketing, go to Reports > Purchases,
Auctions, Sales, Deaths and Culls > Sale Catalogue. The sale catalogue is basically the same as the Animal
Summary report, but with options to include your own logo, lot number and comments for each animal.
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•

28.

When animals were sold, hunted, died, stolen or left the herd for other reasons, this should be recorded in
BenguFarm GAME to keep your herd list up to date. Please note: Do NOT delete the animal records of
animals leaving the flock (non-active animals) from BenguFarm GAME, as they may in some way be
connected to other animals in the database. If an animal is deleted, the pedigree or progeny of the related
animal(s) will no longer be complete.
To create a list on which animals' sale-/hunting-/death data can be recorded, go to Reports >
Animal Lists and Numbers > Herd List. To the far right are columns to record the date and reason why
animals left the herd.
To record (or edit/delete) sales data (to whom sold, date sold, reason for selling, weight, price, etc.) of
sold animals or the left-herd data of animals that left the herd for reasons other than sold
(e.g. died, stolen, etc.), go to Other Data > Sales, Deaths and Culls. Use the Help function if necessary.
Please note:
o When an animal that has left the herd (sold or died), they are NOT removed automatically from
the camp and/or group(s). If you do want to remove the animals from the camp and/or group(s)
they were in when they left the herd, this can be done, but this is not necessary as you normally
only work with the active animals in a camp or group.
o If a breeding bull is sold or died, remember to remove the Breeding/AI Bull mark from the bull's
record. [Animals > Add and Edit Animals > General > Breeding/AI Bull].
If the buyer is also a BenguFarm user, you can send the buyer the relevant animals’ data
electronically which he can then import into his BenguFarm. To create this electronic file
containing the data of the sold animals, go to Data Send/Import > Send > BenguFarm Animal Transfer
File. Please note:
o If data from more than one species has to be sent, make sure you create a separate Animal
Transfer File for each species. The following data is not included in the Animal Transfer File:
▪
Camps and groups
▪
Vaccinations, Dosings, Disease Tests, Diseases and Treatments
▪
Procedures
▪
Purchases and Sales
▪
Photos and Documents.
To create a report of animals that were sold or that left the herd for other reasons, go to
Reports > Purchases, Auctions, Sales, Deaths and Culls > Sales, Deaths and Culls.
To create a report of the animals which were added to the herd (calves born, animals bought,
moved from another herd) and left the herd (sold, died, moved to another herd, etc.) for a specific
period, go to Reports > Animal Lists and Numbers > Animal Numbers Reconciliation. For this report to
reflect the correct numbers and display all relevant values, it is necessary that:
o The animal numbers and values are calculated and stored regularly:
o All applicable data such as animals born, purchased, moved from another herd, sold, died and
moved to another herd recorded with, where applicable, the purchase price, selling price and loss
value must have been recorded.
To view the sale data of an animal on the main window, go on the Animal View to the General view
window and scroll down to the sale data fields or go on the Herd View to the Sales and Deaths section.
Tip: Remember to turn on the Non-active filter to see the animal in the list of animals.
To restore an animal that was wrongly recorded as sold or dead, go to Animals > Add and Edit
Animals (Single Animal Layout). Turn on the Non-active filter and select the animal in question. On the
General Data screen, change the Status to Active. On the Miscellaneous Data screen, remove the
Cancelled record and Save. On the same screen, click on Edit Detailed Transfer / Cancellation Record. The
Sales, Deaths and Culls screen will now open and the animal's record will be automatically loaded. Select
the record and click Delete and Save.
Tip: To create a report of all activities recorded in BenguFarm during a selected period, go to
Reports > Administration > Log of Recorded Activities.

Move animals to another herd
Please note: If BenguFarm Game is set up with one herd per species (as recommended), the
moving of animals between herds is not applicable.
•

To create a new herd (species), see paragraph 7.
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•
•

•
•
•

•

How to move animals in BenguFarm from one herd to another herd, depends on whether the two herds
are in the same database or in different databases. Tip: To see if the respective herds are on the same
database, go to File > Change Active Herd To > List All and Select.
If the two herds are on the same database, you can simply move the animals from one herd to
another. Go into the herd from which you want to move the animals to Other Data > Move Animals to
Another Herd. Mark the animals involved in the "S" column, and then select at the top of the window, the
herd to which the animal must be moved, enter the date, select the reason and Save. Use the Help
function if necessary. Please note: Remember to change the relevant animal's camp and/or management
group, where applicable.
To create a report of animal movements between herds on the same database, go to Reports >
Camps and Herds > Herd Movements.
To view the herd movement data of an animal on the main window, go on the Animal View to the
General view window and scroll down to the Herd information fields.
To create a report of the animals that were added to the herd for a certain period (animals born,
purchased, moved from another herd) and left the herd (sold, died, moved to another herd), go to
Reports > Animal Lists and Numbers > Animal Numbers Reconciliation. For this report to reflect the
correct numbers and display all relevant values, it is necessary that:
o The animal numbers and values are calculated and stored regularly:
o All applicable data such as animals born, purchased, moved from another herd, sold, died and
moved to another herd recorded with, where applicable, the purchase price, selling price and loss
value must have been recorded.
If the two herds are each on a separate database, you must transfer the animals through an Animal
Transfer File. Go into the herd from which you want to move the animals to Data Send/Import > Send >
BenguFarm Animal Transfer File, select the animals concerned, select the transfer options and create the
Animal Transfer File. Note where the file is saved. To import the Animal Transfer File into the other herd
(on another database), go into the herd to which you want to move the animals to Data Send/Import >
Import > Database > BenguFarm Animal Transfer File. Browse to where the file was saved and click on
Import. Use the Help function if necessary.

Tip: To move animals between camps or other groups, go to Other Data > Move Animals to another
Camp or Group. Use the Help function if necessary.

29.

Update the programme:
•

•

•

•

It is important to always update your BenguFarm programme to the newest version (the version date
appears at the top of the main window, e.g. "BenguFarm (TM) [GAME] v21 Apr 2022). BenguFarm users
are notified by e-mail when a new version has been released on the BenguFarm website
www.bengufarm.co.za.
There are three ways to update your BenguFarm programme via the internet to the newest
version:
o If you are on-line and the automatic update option is selected (Settings > Herds > Reminders >
Automatically check for Newest BenguFarm Update), BenguFarm will remind you when a new update
is available. Follow the instructions to update your BenguFarm.
o To initiate the above process manually, go in BenguFarm to File > Update from Web and follow the
instructions.
o Close your BenguFarm, go to the BenguFarm website www.bengufarm.co.za > Updates and download
and install the update. The instructions how to do this are available on the particular website page.
Please note:
o Windows may give a security warning and ask the user whether the file must be run of not.
Select "More Info" and/or "Run" / "Run Anyway" to run the update file.
o If your computer does not allow you to download the update file, de-activate your
computer’s anti-virus program temporarily and try again. (The default settings of some
anti-virus programs, e.g. Avast, Avira, Kaspersky, McFee and Norton, are very aggressive and may
see the BenguFarm updating file (.exe format) as a risk and block it, with the result that you will
not be able to continue with the BenguFarm installation).
When you have finished the update process, open BenguFarm again and see if the applicable version’s
date appears on top of the main window, e.g. "BenguFarm (TM) [GAME] v21 Apr 2022.
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30.

Tip: To see what has been added and changed in BenguFarm, go to www.bengufarm.co.za > Downloads
> Newsletter. Select the latest newsletter and look for the What’s New section.

Renew the registration of the programme:
Your BenguFarm programme will annually warn you about a month before your BenguFarm license is about to
expire. BenguelaSoft BK will send you an invoice for the license fee about a month before your BenguFarm
license is about to expire. If for some reason you didn’t receive an invoice (please ensure that we have your
correct e-mail address), please contact Naomi Havenga at 082 696 8306 or send an email to
accounts@benguelasoft.co.za.
To re-register your BenguFarm, follow these instructions:
• Please send the proof of payment of the license fee to Tim Pauw at accounts@benguelasoft.co.za.
• For the automatic re-registration function in BenguFarm to work, the following must be in place:
o Your computer must be online on the internet at the time that you open BenguFarm;
o Your BenguFarm module’s license fee must be paid-up;
o The license fee payment must be recorded on the BenguFarm client database (please allow 5 working
days for this); and
o Your BenguFarm account number (BPU....) must be recorded in your BenguFarm. (If your account
number is recorded, it will be displayed next to your account name at the top of the main window).
o The relevant BenguFarm Computer Identification Code (at the top of the registration window) must
already be recorded on the BenguFarm client database.
• If all this is in place and your BenguFarm registration has expired or is about to expire in the near future,
your BenguFarm will, when you open it, link via the internet to the BenguFarm client database at
BenguelaSoft and automatically renew your BenguFarm registration. A message “Re-registration
successful. You have access until [date]” will appear on the screen. In such cases, it is not necessary to
enter the new registration codes manually on the registration screen.
• Irrespective of the automatic re-registration option, BenguelaSoft will in any case send you, within five
working days from date of receipt of payment, an e-mail with the registration and access codes for the
Computer Identification Codes (CICs) we have on record for you (see note below). If the automatic reregistration was unsuccessful, go to Options > Registration and complete the registration code and access
code for the specific CIC on the registration window and click Register/Reregister.
• If the automatic re-registration was unsuccessful, and the CIC is not included in the e-mail or
SMS or if you do not have an e-mail facility, contact Naomi Havenga at 082 696 8306 or send her an
email to accounts@benguelasoft.co.za while you are on the registration window, and supply her with your
BenguFarm account name and number (beginning with BPU) and the CIC for which you need a
registration code. She will then supply you with a registration code and access code which you need to
enter on the registration window. Then click on Register/Reregister.
Please note:
o
Please make sure that we have your correct e-mail, phone number and other contact details on
record. If you are on-line on the internet, you can check and, if necessary, change your account
details via BenguFarm by going to Options> View/Update my Account Information. Alternatively,
please contact Naomi Havenga.
o
Each database in BenguFarm has a different CIC. Also, the CIC of each computer on which
BenguFarm is installed is different. Therefore, you will need to supply the CICs of all the databases
on all the computers on which BenguFarm is installed and get a registration code and access code for
each. To get the CICs of the other databases, change the active herd to the applicable database (File
> Change Active Herd to) and then go to Options > Registration. Do the same for each computer on
which BenguFarm is installed.
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PART C – ADDITIONAL AND ADVANCED FUNCTIONS:
File
31.

Recalculate summary data:
•

32.

Recalculate expected calving dates:
•
•

33.

To recalculate inbreeding percentages, go to File > Support> Recalculate Inbreeding Percentages.

Find duplicate animals:
•

•
•
•
•

36.

To recalculate automatic diary entries, go to File > Support> Recalculate Automatic Diary Entries.

Recalculate inbreeding percentages:
•

35.

Expected calving dates must be recalculated if the Youngest Age at 1st Mating, Rest Period from Calving to
Mating or Minimum, Normal or Maximum Period Pregnancy settings [Settings > Herds> Mating, Pregnancy
and Calving] has been changed for the affected herd.
To recalculate expected calving dates, go to File > Support > Recalculate Expected Calving Dates.

Recalculate automatic diary:
•

34.

To recalculate summary data, go to File> Support > Recalculate Summary Data.

BenguFarm will not normally allow duplicate animal records (animals with the same IDnr) to be created,
but when an animal record was created by hand or imported from some file and then also imported from
another file, it is possible in certain circumstances that duplicate records may arise. An example is when
data was first imported from another software package in BenguFarm and then also imported from a Logix
file. For animals that did not have computer numbers in Studmaster or where the computer number was
incorrect, duplicate records will then be created.
To search for animals with the same visual or electronic ID (EID) number or computer
number, go to File > Support > Find Duplicate Animals. Please note: Animals with duplicate numbers
are searched for across all herds in the applicable database.
If there are animals in the same herd with the same ID number, this can lead to several problems. If there
are really two animals with the same ID number (e.g. one purchased and one self-bred), add a letter at
the back of one of the animal’s number to make the animals' numbers unique, e.g. 190022A.
To create a report of duplicate animals, click on Display Report.
Duplicate animal records can be corrected manually by first determining what data (general animal data,
pedigree data, progeny data, weights, etc.) differ between the two animals involved, secondly completing
one of the two animals' data and then thirdly delete the other animal. However, it is a long and arduous
process, especially when there are many such duplicate animals. However, there is an administrative
function in BenguFarm [File > Support > Administrative Functions] that performs this merge process
programmatically. To access the Administrative Functions, a password is needed. Contact your BenguFarm
agent for assistance using this administrative function to merge duplicate animal records into BenguFarm
and delete the other record.

Change ID numbers and/or names:
•
•
•

•

Please note: It is strongly recommended that a backup of the relevant database be made before using
this feature.
Go to Settings > Herds > ID Methods and Numbering and make sure the Default ID Format is set up
correctly.
Go to Animals > Edit Animals (table layout). At Select Columns to View, select the fields HDM, Year,
Sequence Number and, if applicable, Prefix (Flock Name). Make sure these fields, where applicable, are
filled in and correct for ALL active animals in the herd concerned, as the first three fields will be used to
recreate the IDnrs according to the Default ID Format setting. If anything has been added or changed,
click Save.
To change animals' ID numbers and/or names in BenguFarm GAME, go to File > Support > Change ID
Numbers and/or Names and select the appropriate option.
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37.

Administrative functions:
•

38.

BenguFarm has various administrative functions to correct or change data. Go to File > Support >
Administrative Functions. Your BenguFarm agent will refer you to these functions when needed and
provide you with the password to access these functions. Please note: It is strongly recommended that a
backup is made of the relevant database before any administrative function is used.

Troubleshooting and problem solving:
•

•
•

If you encounter an error message in BenguFarm GAME (e.g. "An unhandled exception has occurred..."),
the following should solve it in most of the cases:
o Go to File > Support > Test Data Structures and DBNull Values.
o Go to File > Support > Compact and Repair Database.
o Go to File > Support > Recalculate Summary Data.
o Go to Settings > Herds > General and make sure that all applicable settings are in place and
correct.
o Close BenguFarm and open it again.
If the above steps do not solve the problem, go in BenguFarm to File > Update from Web OR close
BenguFarm, open your Internet browser and go to www.bengufarm.co.za > Downloads > Updates.
Download the latest update, install it and open BenguFarm again.
If this still does not solve the problem, contact your BenguFarm GAME agent.

Animals
39. Notes:
•

•

40.

Appearance remarks:
•

•

41.

To record (or edit/delete) a general note (e.g. "Half-sister of most expensive bull at National Sale
2012") on a record of an animal, go to Animals > Add & Edit Animals (Single Animal Layout) >
Miscellaneous Data > Notes. Notes can also be recorded on the Animal View of the main window
on the Notes view window. This is the only view window where data can be entered and saved. (Click
on the “stiffy” disk icon to save the new note).
Notes can be included in the Animal Summary report [Reports > Animal, Pedigree and Progeny > Animal
Summary]. Notes can also be included in My Reports [Reports > My Reports > Animal Data. Click on
Report Columns (Layout) and then select General > Notes].

To record (or edit/delete) appearance remarks (e.g. Left horn broken) of an animal, go to Animals >
Add & Edit Animals (Single Animal Layout) > General > Appearance Remarks. Select the remark(s) under
the relevant section and mark it (e.g. under the Horns section > Left horn broken). Appearance
Remarks can also be recorded and saved on the Animal View of the main window on the
Notes view window under the Appearance Remarks heading.
Appearance Remarks can be included in the Animal Summary report [Reports > Animal, Pedigree and
Progeny > Animal Summary]. Appearance Remarks can also be included in My Reports [Reports > My
Reports > Animal Data. Click on Report Columns (Layout) and then select General > Appearance
Remarks].

Family lines:
•
•

•
•

The purpose of recording family lines is to indicate that an animal was bred from a specific family.
Record can be kept of either dam lines or sire lines.
To set whether the program should keep record of dam lines or sire lines, go to Settings > Herds
> Matings, Pregnancy and Calving and select Breed Dam Lines or Breed Sire Lines and, if applicable, Force
Selected Line. If Breed Dam Lines is selected, a calf will receive the family code of the dam. If the dam
does not have a family line, the calf gets the family line of the sire. Sire lines just the other way around. If
Forced Selected Line is selected and for example Breed Dam Line was set up and the dam does not have a
family code, the father's family code will NOT be used.
The family code can be recorded for an animal on the Calving screen, Add and Edit Animals screen
as well as the Edit Animals screen.
On the calving screen, a calf will be automatically linked to the dam's family line, if the dam's
family line has been recorded, or the sire's family line, if the sire's family line has been recorded.
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•
•
•

42.

To view an animal's family code on the main screen, go to the Animal View > Birth > Family Code
and on the Herd View to the Birth section.
Animals from a specific family line can be selected with the Choose Animals screen> Choose
Animals by Group(s) / Filter(s) > Family Line.
The family code can only be included in the My Reports by going to Reports > My Reports > Animal
Data. Click Report Columns (Layout) and then choose Birth > Family Line.

DNA verified parentage and bloodlines:
See paragraph 22 how to certify the DNA verified parentage of animals in BenguFarm.

43.

Data navigator:
•

44.

Search animal:
•

45.

To search for an animal on a different number (e.g. microchip/electronic number, computer number,
DNA number, etc.) in BenguFarm GAME, go to Animals > Search Animal. This feature is especially handy
to see what the ear tag number was when an animal has lost its visual tag.

Re-assign a microchip number (EID) to a different animal:
•
•
•

•

46.

The Data Navigator window is very useful to display various types of data together on one window for
the entire herd (default option) or a selected group of animals. Changes to data and removal of records
can also be made on the applicable data window via the Data Navigator window. Tip: The Data Navigator
window can also be used to select and sort animals and to quickly print a report. It is indeed a very useful
window. Use the Help function if necessary.

PLEASE NOTE: This feature is specifically for use by cattle, sheep and goat farmers where electronic
number discs (EIDs) are attached externally to the ears of animals. It is therefore normally NOT a
function that will be used in game, where microchips are implanted subcutaneously.
To re-assign the number of a microchip (EID) that was assigned to on an animal to a new
animal in BenguFarm GAME, go to Animals> Re-assign Microchip Number (EID) to a Different Animal.
Select the applicable animal and enter the microchip number (EID) to be assigned to the animal. The
animal that currently has this microchip number (EID) will be listed below and the microchip number
(EID) will automatically be deleted from that animal, i.e. after the relevant microchip number (EID) was
entered at the new animal and saved, the microchip number (EID) field for the previous animal will be
blank. If necessary, a different microchip number (EID) can be entered for this animal, but it's unlikely, as
a re-assignment of a microchip usually happens where the animal that currently has the chip, was
slaughtered or sold.
Please note:
o BenguFarm do NOT keep record of the previous animal(s) that had a particular microchip number.
If you want to keep such records, we suggest that you leave the microchip number with the
previous animal, but add a character to it to make a unique number, e.g. the first animal that had
the microchip number 123456789 is 123456789-A, the 2nd animal that had this microchip number
(EID) 123456789-B, etc. The animal that currently has the microchip number is of course only
123456789.
o If you only use electronic identification (EIDs), please see Settings > Herds > Create IDnr (Visual)
from EID (Microchip Number) where no IDnr Specified.

Change breeders, owners and/or keepers:
•

To change one or several animal's breeders, owners and / or stands BenguFarm GAME, go to Animal>
Change Breeders, Owners and / or Keepers. Use the Help function if necessary.

Reproduction:
47. Synchronisation: (if applicable)
•
•

Make sure the applicable values are set up at Settings > Herds > Mating, Pregnancy and Calving for
# Days from Insert to First Injection; # Days from Insert to Second Injection; # Days from Insert to
Remove and # Days from Remove to AI / Lapa.
To create a list of all breedable heifers and cows, go to Reports > Matings, Pregnancies and
Calvings > Breedable Heifers and Cows (recording list).

36

•
•

•

To record (or edit/delete) synchronisations as well as subsequent actions, go to Reproduction >
Synchronisation. To record additional / follow-up actions data to existing records, click Load Existing
Records.
To create a report on synchronisations as well as subsequent actions, go to Reports > Matings,
Pregnancies & Calvings > Synchronisation. Please note: Actions already done are displayed in normal
font; actions that still need to be done are shown in bold and actions that should already have been done
are shown in bold red.
To view synchonisation data of an animal on the main screen, go to the Animal View to the Mating
and Pregnancy History view screen (the Show Synchronization option at the top right of the view subscreen must be enabled) or on the Herd Layout to the Sync section.

Health
48. Tests for diseases:
•
•
•
•

49.

To create a list on which tests for illness can be recorded, go to Reports > Diseases, Injuries, and
Treatments > Disease Tests (recording list). [Not available yet]
To record (or edit/delete) the results of disease tests, go to Health > Disease Tests.
To create a report of the results of disease tests, go to Reports> Diseases, Injuries and
Treatments> Disease Tests.
To view an animal's results of disease tests on the main screen, go on the Animal View to the
Vaccinations, Dosings and Diseases Tests > Disease Tests view window. To display disease tests on the
Herd View, go on the main window’s Herd View to Display Options > click the Set Up My Columns to
Display (icon at the top). [Not available yet]

Vaccinations, dosings, dip and supplements:
•
•

•

•
•

•
•
•

To record vaccines, remedies, dips and supplements stock, see paragraph 51.
To create a list of animals in a specific camp that has not been vaccinated, go to Reports >
Diseases, Prevention and Treatment > Vaccinations, Dosings, Dips and Supplements. On the left, select
the criteria of the vaccinations that have been done, e.g. between two dates. On the right, select the
appropriate camp. Then select the option "Not Vaccinated/Received Remedy or Supplement."
To create a list for recording inoculations, dosings, dip and supplements, go to Reports >
Diseases - Prevention & Treatment > Vaccinations, Dosings, Dip, Supplements & Procedures (recording
list). In Select Items to Print, select the vaccinations/dosings/dip/supplements to be recorded and add it
with the arrow pointing to the right to the Items to Print on Report. Tip: To print the dosage (as set up at
Health > Vaccines, Remedies, Dips and Supplements Stock), check the Print Vaccine/Remedy Dosage
option.
To record (or edit/delete) vaccinations, dosing, dip and supplements, go to Health > vaccinations,
Dosings, Dip and Supplements. Use the Help function if necessary.
Tip: Information such as default dosage, withholding period and expiry date of vaccines, remedies,
dips and supplements can be recorded on the stock register [Health > Vaccines, Remedies, Dips and
Supplements Stock]. When Vaccinations, Dosings, Dips and Supplements are recorded, the cost per animal
will be calculated automatically from the Vaccines, Remedies, Dips and Supplements Stock, provided the
batch number is entered. If a batch number is not entered, the last purchase's unit price (total price / #
units) will be used.
To create a report of vaccinations, dosings, dip and supplements done, go to Reports > Diseases
- Prevention & Treatment > Vaccinations, Dosings, Dip and Supplements.
To view the vaccinations, etc. data of an animal on the main window, go on the Animal View to
the Vaccinations and Dosings view window. To display it on the Herd View, go on the main window’s Herd
View to Display Options > click the Set Up My Columns to Display (icon at the top).
Tip: It is recommended that, where necessary, the default list of vaccines, remedies, dips and
supplements be expanded with specific drugs that you use. This can be done by going to Settings >
Vaccines, Remedies, Dips and Supplements. Vaccines, remedies, dips and supplements in the default list
that do not apply to your herd can be disabled by removing the tick mark in the In Use and Device (e.g.
the MOBILE app) columns.
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50.

Diseases, injuries and treatments:
•
•
•

•
•
•

51.

To record medicine stock, see paragraph 52.
To record (or edit/delete) diseases, injuries and treatments, go to Health > Diseases, Injuries and
Treatments. Use the Help function if necessary.
Tip: Information such as default dosage, withholding period and expiry date of medicines can be
recorded on the stock register [Health > Medicine Stock]. When Treatments are recorded, the medicine
cost per animal will be calculated automatically from the Medicines Stock, provided the batch number is
entered. If a batch number is not entered, the last purchase's unit price (total price / # units) will be used.
To create a report of diseases, injuries and treatments, go to Reports > Diseases – Prevention and
Treatments > Diseases, Injuries and Treatments.
To view the diseases, injuries and treatments of an animal on the main window, go on the
Animal View to the Diseases and Treatments view window.
Tip: It is recommended to, where necessary, extend the default list of medicines with the specific
medicines you use. This can be done by going to Settings > Medicines. Medicines in the default list that do
not apply to your herd can be disabled by removing the tick mark in the In Use and Device (e.g. the
MOBILE app) columns. The same applies to the Diseases, Injuries and Parasites settings.

Vaccines, remedies, dips and supplements stock:
•
•
•

52.

To record (or edit/delete) vaccines, remedies, dips and supplements (such as multimineral or
multivitamin) stock (optional), go to Health > Vaccines, Remedies, Dips and Supplements Stock. Use the
Help function if necessary.
When vaccinations, dosing, dip and supplements records are recorded, the vaccines, remedies, dips and
supplements stock is updated automatically.
On the Diary and Management Calendar screen under the Stock near Expiry category, a warning will
appear if the relevant batch of vaccine is near the expiry date.

Medicine stock:
•
•
•

To record (or edit/delete) medicine stock (optional), go to Health > Medicine Stock. Use the Help
function if necessary.
When treatment records are recorded, the medicine stock is updated automatically.
On the Diary and Management Calendar screen under the Stock near Expiry category, a warning will
appear if the relevant batch of medicine is near the expiry date.

Performance Testing
53. Measurements and Scores of other traits (not horn measurements):
•
•

Please note: To record horn measurements, see paragraph 25.
To create a list on which measurements or scores of various traits can be recorded, go to Reports
> Weights, Measurements, Performance Testing and Breeding Values > Measurements and Scores
(recording list).
To record (or edit/delete) measurements or scores (e.g. Condition Score or General Appearance Score)
of traits, go to Performance Testing > Weights, Measurements and Scores not Linked to a Test >
Measurements and Scores. Please note: Only measurements or scores with numeric values can be
recorded here. To record traits with alpha values, see paragraph 67.
To set up additional traits, go to Settings > Traits.
To create a report of measurements or scores, go to Reports > Weights, Measurements, Performance
Testing and Breeding Values > Measurements and Scores Report.
To view an animal's measurements or scores on the main window, go on the Animal View to the
Measurements and Scores view window. To display measurements and scores on the Herd View, go on the
main window’s Herd View to Display Options > click the Set Up My Columns to Display (icon at the top).

•

•
•
•

Other data
54. Rhino horn register:
•
•

Please note: This feature is only available if the relevant herd is setup with species as White or Black
Rhino.
To keep a register of rhino horn that was cut off, go to Other Data > Rhino Horn Register.
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•

55.

Diary and management calendar:
•
•
•
•
•

56.

•

•
•
•
•

•
•
•

See paragraph 66, section Expenditures recording in BenguFarm for recording of expenditures per animal
or per camp.
To record (or edit/delete) general herd expenditures (e.g. labour, diesel, SA Stud Book fees,
breeders’ society fees, etc.) and income for the particular herd, go to Other Data > General Herd
Expenditures/Income. Use the Help function if necessary.
To create a report of general herd expenditures for the particular herd, go to Reports > Herd
Analysis > General Herd Expenditures/Income.
To create a report of all income and expenditures recorded for the particular herd, go to
Reports > Herd Analysis > Herd Income and Expenditure Summary.

Rainfall:
•
•
•

59.

The Procedures screen is intended to record activities or procedures such as calves weaned, hooves cut,
biopsies taken, semen tests, sheath washing, disease tests, animals marked, etc.
To create a list on which procedures can be recorded, go to Reports > Diseases – Prevention and
Treatment > Vaccinations, Dosing, Supplements and Procedures (recording list). At Select Items to Print,
select the procedures you want to record and add it with the arrow pointing to the right to the Items to
Printed in Report.
To record (or edit/delete) procedures, go to Other Data > Procedures. Use the Help function if
necessary.
To create a report of procedures, go to Reports > Other Reports> Procedures.
To display the procedures of an animal on the main screen, go on the Animal View to the
Procedures view screen. To display it on the Herd View, go on the main window’s Herd View to Display
Options > click the Set Up My Columns to Display (icon at the top).
Tip: It is recommended to, where necessary, extend the default list of procedures. This can be done by
going to Setting > Procedures.

General Herd Expenditures and Income
•

58.

BenguFarm GAME has an internal diary that is integrated with the management calendar function.
To set up your own management calendar, go to Settings > Management Calendar Settings. Use the
Help function if necessary.
To view the management tasks and other diary entries, go to Other Data > Diary and Calendar
Management. Use the Help function if necessary.
At Settings > Herds > Reminders you can set the diary and integrated management calendar to be
displayed when BenguFarm GAME is opened (by default it is enabled) and set the period (default is 7
days) for diary items to be displayed.
Please note: When calves' birth data is recorded on the Calving window, BenguFarm will normally
automatically calculates the weight dates for performance testing for the relevant calves and display it in
the BenguFarm diary.

Procedures:
•

57.

To create a report of the rhino horn register, go to Reports > Other Reports > Rhino Horn Register.
[Currently not yet available].

To import historical rainfall data from Excel, see Appendix A.
To record (or edit/delete) rainfall (per location), go to Other Data > Rainfall. Use the Help function if
necessary.
On the same screen a report (with various options) can be created of rainfall.

Miscellaneous stock:
•

To record (or edit/delete) miscellaneous stock (licks, feed, hay, etc.), go to Other Data >
Miscellaneous Stock. Use the Help function if necessary.
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60.

Camp activities:
•
•
•
•

61.

To record (or edit/delete) activities linked to a specific camp (e.g. feed and/or licks put out, burned,
de-bushed, feeding place moved, fence maintenance, drinking place cleaned), go to Other Data > Camp
Activities. Please note: Camp activities are not linked to the animals in the specific camp at that time.
Stock items such as concentrate feed, lick and hay recorded at Miscellaneous Stock (see above) are
automatically updated if the put out of it in camps were recorded at Camp Activities if the appropriate
stock item is selected and the amount indicated.
To create a report of camp activities, go to Reports > Camps > Camp Activities.
To create a report of feed usage per camp, go to Reports > Weights, Measurements, Performance
Testing and Breeding Values > Feed Usage. This report provides a summary of feed usage as recorded at
Camp Activities as well as feeding stations where animals’ individual feed intakes are recorded.

Animal sightings:
•
•
•

62.

This function is mostly used by rhino breeders to keep record of animal sightings.
To record (or edit/delete) animal sightings on a specific date and camp and/or GPS
coordinates, go to Other Data > Animal Sightings.
To create a report of animal sightings, go to Reports > Animal Lists and Numbers > Animal
Sightings. Tip: With the Animal Sightings vs Camp option, all the animals seen are listed, and next to
each animal the camp in which it is currently in BenguFarm. With the Camps vs. Animals Sightings option,
all the animals that are in BenguFarm in a certain camp(s) are listed and next to it in which camp and
when they were last seen.

Insurance:
•
•

63.

To record (or edit/delete) insurance data of animals, go to Other Data > Insurance.
To create a report of insurance data, go to Reports > Other Reports > Insurance.

Move animals to another place:
•
•

64.

To record (or edit/delete) the (temporary) movement of animals from the farm to another place
(keeper), e.g. a farm of another farmer, go to Other Data > Move Animals to Another Place. Use the
Help function if necessary.
Please note: To move animals between herds (of the same species, if applicable), go to Other
Data > Move Animals to Other Herd. To move animals between camps or other groups, go to Other
Data > Move Animals to another Camp or Group.

Awards:
•
•
•

To record (or edit/delete) awards of animals, go to Other Data > Awards.
Awards can be displayed in the following reports:
o Breeding Herd Selection [Reports > Inspections and Selections > Breeding Herd Selection]
o My Reports [Reports > My Reports > Animal Data > Columns > Awards]
To view the awards of an animal on the main screen, go on the Animal View to the General view
screen and scroll down to the Awards fields.

Reports
65. My animal data reports:
•
•
•
•
•
•

The My Animal Data Reports function is very powerful to set up your own customised reports
and save them for later use. Go to Reports > My Reports> Animal Data.
Click at the top of the screen on Choose Animals (Criteria) and then at the bottom on Choose Animals
with Choose Animals Window OR set up criteria to select animals by clicking the "+" bottom right of the
screen. Use the HELP function if necessary.
Click at the top of the screen on Report Columns (Layout) and select under the relevant section the
fields you want included in the report.
Click at the top of the screen on View Report to see how the report will look like. If you want to sort the
animals on a specific field, click on the column heading.
Click at the bottom right of the screen on Display Report. Choose Print or Export.
To save the criteria and/or the layout for future use, click at the bottom of the screen on Save Criteria
and Layout.
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•
•

66.

To load saved criteria and/or layouts, click at the bottom of the screen to Load Criteria and Layout.
Tips:
o On the Report Columns screen, empty columns can also be selected to record, for example,
comments or notes.
o On the My Reports> Report Columns (Layout) in the column Heading of Column on Report, the
default column headings can be changed with custom headings. The newly selected column
headings can be saved with the "stiffy" icon at the bottom right of the screen.
o The saved criteria can be used on the main window’s group filter as well as on the Choose Animals
screen to select animals that meet the criteria.
o The My Animal Data Reports can be used to set up your own layout for certain reports, e.g. Animals
per Camp or Group, Herd List, Pedigree or Progeny Summary.
o Remember to make a backup of your own reports' layouts. [File > Backup and Restore> Backup My
Saved Report Layouts].
o The My Animal Data Reports have certain limitations in terms of the columns available to include in a
report. Another option is to create a report on the main window's Herd View with the required
columns. To do this, see paragraph 5.

Herd Analysis:
•

Averages and trends:

The purpose of the Averages and Trends report is to graphically compare the average
measurement/calculated value of a selected trait(s) for the herd concerned for a selected period. This
function can also be used to compare sires’ progeny averages.
To create an Averages and Trends report, go to Reports > Herd Analysis > Averages and Trends. Use
the Help function if necessary.

•

Expenditures recording in BenguFarm:
•
•

•

It is recommended that costs and prices be recorded without VAT.
Stock purchases: The total purchase price can be recorded on the following screens:
o Health > Vaccines, Remedies and Supplements Stock.
o Health > Medicines Stock.
o Other Data > Miscellaneous Stock (e.g. lick, feed, concentrates).
o Reproduction > Semen Stock.
Expenditure per animal: Certain expenditures can be recorded in BenguFarm per animal. The following
expenditures can be recorded per animal on the following screens:
o Reproduction > Matings > Artificial Inseminations. Please note: The straw cost per animal AIed
is calculated automatically from the Semen Stock, provided the Semen Type is selected as Frozen
on the AI window and the purchase price was recorded on that the Semen Stock window.
o Reproduction > Pregnancy Tests.
o Reproduction > Embryo Implants. Please note: The cost per animal is not automatically
calculated from the Embryo Stock.
o Health > Disease Tests.
o Health > Vaccinations, Dosing and Supplements. Please note: The cost per animal is calculated
automatically from the Vaccines, Remedies, Dips and Supplements Stock, provided the batch
number is entered. If a batch number is not entered, the last purchase's unit price (total price / #
units) will be used.
o Health > Diseases, Injuries and Treatments. Please note: Provision is made for the recording of
both veterinarian and/or medicine expenditures. The medicine cost per animal will be calculated
automatically from the Medicines Stock, provided the batch number is entered. If a batch number
is not entered, the last purchase's unit price (total price / # units) will be used.
o Other Data > Procedures. Expenditures for procedures (e.g. fertility tests, DNA analyses, ear tags,
etc.) that are done per animal can be recorded here.
o Other Data > Purchases. Costs at purchase not included in the purchase price (e.g. transport
costs) can be recorded in the Cost per Animal field.
o Other Data > Sales Deaths and Culls. Costs at sales not included in the sale price can be recorded
in the Cost per Animal field.
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•
•

•

Expenditures per Darting Event:
o Other Data> Arrow Data: The veterinary costs as well as the helicopter / game capture costs, if
applicable, can be recorded if a Veterinarian visit is set up.
Expenditure per Camp: Certain expenditures (e.g. lick put out, camp de-bushed, camp burned, fences
erected, etc.) cannot be recorded per animal, but it can be recorded per camp. Considering the number of
animals in the camp, an average cost per animal can be calculated. This type of expenditure per camp can
be recorded on the Camp Activities screen [Other Data > Camp Activities]: Please note: If the item
concerned, e.g. winter lick, was recorded at Miscellaneous Stock and the relevant stock item selected on
the Camp Activities screen, the expenditure will be calculated automatically. Otherwise, the expenditures
can be recorded on the Camp Activities screen.
Expenditure per Herd: Certain expenditures (e.g. labour, fuel, breeders’ society fees, etc.) cannot be
recorded per animal or per camp but can be recorded as general expenditures for the herd concerned.
These types of expenditures per herd can be recorded on the General Herd Expenditures Screen [Other
Data > General Herd Expenditures]. Tip: If you have more than one herd on the same database, general
expenditures can be recorded in the ALL herd, where applicable. Expenditures that can be recorded per
animal (e.g. fertility tests, pregnancy tests, DNA analyses) but not being recorded per animal, can be
recorded here as a total expenditure for the relevant herd.

Herd Income and Expenditure Summary:
•
•

The purpose of the Herd Income and Expenditure Summary report is to calculate the income and
expenditures for the herd concerned per item for a specific period (e.g. for a financial year).
To create a Herd Income and Expenditure Summary report, go to Reports > Herd Analysis > Herd
Income and Expenditure Summary. Please note: Stocks purchased (see above) will not be shown as an
expenditure on this report. It will only be shown as expenditure if its use was recorded per animal, camp
or herd.

Settings
67. My animal fields:
•

You can define your own fields if you want to record data for which there is no provision elsewhere (e.g.
Eye Pigment Percentage). To setup these fields, go to Settings > My Animal Fields.
To record data in these fields, go to Animals > Edit Animals (Table Layout) OR go to Animals > Add & Edit
Animals (Single Animal Layout) > My Fields.
To view data recorded in these fields on the main window, go on the Animal View to the My Fields view
screen. To display it on the Herd View, go on the main window’s Herd View to Display Options, select the
appropriate field(s) under the My Columns section, and click Save Options as Herd Default. Close and reopen BenguFarm, then go on the main window’s Herd View to the My Columns section.
My Fields can only be included in the My Animal Reports by going to Reports > My Reports > Animal Data.
Click on Report Columns (Layout) and then select My Fields.

•
•

•

Options
68. View/update my account details:
•

To check your BenguFarm account information online and/or update certain information, go to Options>
View / Update My Account Details.
This screen can also be used to request the latest license invoice if you have not received or have lost it.
Please note: This feature only works if the computer is online, the BenguFarm account number (BPU ....) is
recorded in BenguFarm and the account number and the relevant database's Computer Identification Code
are recorded on the BenguFarm admin system. If your computer does not allow you to connect, de-activate
your computer’s anti-virus program temporarily and try again.

•
•

69.

Action Keys
•
•

The purpose of action keys is to quickly insert certain info that is used frequently, e.g. your herd's herd
designation mark letters, when an animal is searched by ID number. Suppose your herd's herd designation
mark letters are ABC. You can then set these letters as an action key.
To set an action key, click on the “+” at the bottom right of the Define Action Keys screen, enter the
relevant letters (e.g. ABC) in the Value to Display column, select an F key (e.g. F2) in the Key column and
Save.
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•

70.

When an animal's number has to be entered, press the Function (Fn) and the relevant F key (e.g. F2) on
the keyboard at the same time. In the example above, the ABC will then be typed.

Empty database:
•

This feature is used only in exceptional circumstances to empty a database. Your BenguFarm agent will refer
you to this function when necessary and provide you with the passwords to access this function. Please
note: It is strongly recommended that a backup is made of the relevant database before this function is
used.

Add-Ins
71. None.
Help
72. Teamviewer remote support:
•
•
•
•

The BenguFarm agents use TeamViewer software to provide online support directly to your computer.
If you do not have TeamViewer software on your computer, you can download and install it from
www.teamviewer.com. If during installation you choose "Personal" at type of use, use of the program is
free.
If Teamviewer is installed, it can, when required for online support, be opened directly from BenguFarm on
the main screen at Help > Teamviewer Remote Support.
To update the Teamviewer software to the latest version, click Download Latest Teamviewer.
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Appendix A
Import data recorded in Excel
What data can be imported?
With this feature certain animal data recorded in an Excel file, can be imported into BenguFarm. This feature is
specifically for herds that cannot import data from another source (e.g. Logix).
To see a list of all the data which can be imported from Excel into BenguFarm, see the table at the end of Appendix A.
For the program to function optimally, try to import at least the following data: Animal ID No, Sex, Date of Birth,
Species Code and Status Code. If the exact date of birth of the animal is unknown, choose an approximate date, for
example 01-10-2018 for animals born in 2018.

Steps to prepare and import the data:
NB: First make sure the "List Separator" and "Decimal Symbol" settings in Windows is correct. Go to Control Panel >
Region > Additional Settings > List Separator. The "List Separator" should be a comma ",". If it is a semicolon ";",
change it to a comma ",". The "Decimal Symbol" should be a point ".". If it is a comma ",", change it to a point ".".
Click Apply and OK.
1. Preparation of data to be imported:
1.1. Create a separate Excel file for each species (herd).
1.2. For each animal in the herd (cows, heifers, calves and bulls) of which you want to import data into
BenguFarm GAME, you should ensure that all the available data (e.g. Animal ID No, Date of Birth, Sex, Dam
ID No, Sire ID No) is in the same Excel file and sheet. If you need to import data from more than one
sheet, it should be ensured that the Animal ID Nr and Sex is exactly the same on all sheets to prevent that
duplicate animal records are created when importing the additional sheets into BenguFarm.
1.3. Except for the column headings, remove all lines which do not contain animal data, e.g. blank lines,
summaries, etc.
1.4. For data where there can be more one record for a specific type of data (e.g. weights recorded on more
than one date), each additional record (e.g. weigh date and weights) should be created on a separate line in
the Excel sheet to import all the records.
1.5. Ensure that the dates in the Excel file are stored in one of the following two formats, viz. dd/mm/yyyy or
yyyy/mm/dd. E.g. 30 Nov 2010 should be stored as 30/11/2010 or 2010/11/30. The "/" can be any character,
e.g. "-". You can use Excel's Cell Formatting functions to change incorrectly formatted dates. This should
correct the dates' format, depending on how the dates were originally entered into Excel. If a date is not
specified or is not in the correct format, those dates will be created/changed as 01/01/1980 when the data is
imported.
1.6. For the dam and sire to be correctly linked to an animal, the ID No of the dam and sire must EXACTLY
match their ID numbers where these animals are listed in the file as animals. (Small letters will automatically
be converted to uppercase). If a dam or sire is not listed himself as an animal, an animal will be created with
default values. If the dam or sire is unknown, simply leave the applicable field in the Excel file empty.
1.7. To import animal Status (A = Active – Alive in herd or na = Non-Active - Dead/Sold/Not in herd), Species,
Sub-species, Bloodline, Colour and Appearance Remarks, the applicable Status, Species (e.g. SBL for
Sable), Sub-species (e.g. SSB for Southern Sable), Bloodline (e.g. MSI for Matetsi) and Remark codes should
be recorded in the Excel file and match the codes in BenguFarm. For a list of species, sub-species and
bloodline codes, go to Settings > Herds > General and Settings > Sub-species or Bloodlines.
1.8. To import Camps, the particular camps should already be set up in BenguFarm (Settings > Camps). In the
csv file to be imported, the Camp codes as set-up in BenguFarm, should be recorded.
1.9. Horn Measurements:
1.9.1. The unit in which the horn measurements are recorded in the Excel file must match the trait’s unit as
set up under Settings > Traits per Species (choose the unit per trait applicable to this species in the
left-hand list).
1.9.2. All fractions must be converted to decimals (1/8 = 0.125; 2/8 = 0.250; 3/8 = 0.375; 4/8 =
0.500; 5/8 = 0.675; 6/8 = 0.750; 7/8 = 0.875) and the decimal point, not comma, should be used.
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1.9.3. The horn measurements in the Excel file should not include the inch sign (").
1.9.4. For data where there can be more one record for a specific type of data (e.g. horns
measurements recorded on more than one date), each additional record (e.g. measurement date and
measurements) should be created on a separate line in the Excel sheet to import all the records.
1.10. There may be no commas in any fields. All decimals should be points and in the notes field
there may not be any commas.
1.11. Replace all ‘ symbols (if any) with ` (left of the 1 on the keyboard).
1.12. Calculations (such as age, inter-calving period and horn growth) cannot be imported – it will be calculated
in the programme after the data has been imported, provided the necessary data for the calculations is
available.
1.13. Save the Excel (xls or xlsx format) file in CSV (Comma Delimited) format. To do this, open the file in
question in Excel, go to File > Save As… and select File Type "CSV - Comma Delimited" format and click on
“Save”. If there is more than one sheet in the Excel file, each sheet must be saved in a separate CSV file
and imported separately, since you can only save one sheet in a CSV file.
1.14. Open the CSV file in Notepad (not Excel) and check the following:
1.14.1. The List Separator is a comma (,) not a semicolon (;). If necessary, the List Separator setting can be
changed at Computer > Control Panel > Regional > Additional Settings > List separator.
1.14.2. Ensure long numbers (especially DNA numbers) were not converted into exponent format when saving
the file in CSV format.
1.15. Make a note in which line/row in the CSV data file the data starts. For example, in the first row there
can be column headings.
Example of data format for importing into BenguFarm:
ID No

Sex

Date of Birth

Species

Status

Camp

130124
140020
150001
150002
150025
160011
160036
160036
160123
170001
170002
170003

M
F
F
F
F
F
M

15-10-2013
01-10-2014
01-10-2015
01-10-2015
01-10-2015
03-09-2016
27-09-2016

SBL
SBL
SBL
SBL
SBL
SBL
SBL

A
A
A
A
A
A
A

K1
K1
K1
K1
K1
K1
K1

F
F
F
F

11-11-2016
01-09-2017
03-09-2017
05-09-2017

SBL
SBL
SBL
SBL

A
A
A
A

K1
K2
K2
K2

Dam

140002

Sire

130124
130124
130124

Horn
Length
Left
11.5
12.0
10.75
11.0
13.25
12.5
11.0
23.5
10.5
13.0
12.5
11.75

Measure
Date
01-08-2014
03-08-2015
03-08-2016
03-08-2016
03-08-2016
15-08-2017
15-08-2017
20-07-2018
15-07-2017
02-08-2018
02-08-2018
02-08-2018

2. Import the data from the CSV file into BenguFarm:
2.1. Go in BenguFarm to the specific herd (species) for which you want to import data.
2.2. Data should preferably be imported on an empty database. If you import a file a second time into the
same database, BenguFarm GAME will check whether there are already animals with EXACTLY the same ID
No and sex. Thus, please ensure that the Animal ID Nr and sex is exactly the same to prevent that duplicate
animal records are created. To further prevent duplicate animals from being created, uncheck Create Animal
if it does not Exist under Import Options.
2.3. Go to Data Send/Import > Import > Database > Open File Format (CSV).
2.4. Click on “Browse” in on the top of the window and choose the csv file of the specific species you want to
import.
2.5. Import options:
2.5.1. At “Data Start on Line #” choose on which line in the csv file the data starts. (Column
headings should not be imported).
2.5.2. Choose the applicable import options. If unsure, keep the default options.
2.6. Specify what data is stored in what column in the CSV file. To do this, click on the “+” at the bottom
of the window. Now click below the column heading “Data Stored in this Column”. A list of all the data which
can be imported are now displayed. Choose the data that is stored in column 1 (or column A). Repeat this for
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all the columns you want to import. If you don’t want to import a specific column’s data, choose the option
“skip – do not import”.
2.7. In "Sex, Male=" in the "True/Yes" column (far right) fill in what is in the sex column in the csv file for male
animals, e.g. "M". Only the animals with "M" in that column will be imported with sex as male, the rest
automatically as female.
2.8. When all the columns you want to import have been specified and checked, click on “Import”.
2.9. Please note that animal names are changed to capital letters when the data is imported.
2.10. If the animal records are for some reason imported incorrectly, then the incorrect records must first be
removed before the data can be imported again. The data can be removed as follow:
2.10.1. Go to Animal > Edit Animals (Table Layout)
2.10.2. Click on Load a New Selection of Animals (top right of the window), switch on the Non-active filter
(right on top of window) and select all animals (use the Help function if necessary).
2.10.3. Click Remove records (right below on the window) and save.
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Data that can be imported from a CSV file into BenguFarm
General Animal Data:
Animal IDnr (visual )
Birth Date
Birth Date Uncertain
Birth Status (Single, Twins)
Sire ID no
Sire HDM, Year, Sequence no
Sire EID (microchip) no
Dam ID no
Dam HDM, Year, Sequence no
Dam EID (microchip) no
Recipient Cow ID no
Mating Type (code)
Specie (code)
Sub-specie (code)
Section
Bloodline (code)
Colour (code)
Split (Yes/No)
Sex
Herdmark
Year (of Birth)
Sequence Number
Animal ID (officially )
Animal Name
Family Line
Microchip Number (EID)
Microchip Place Implanted
Microchip Date Implanted
DNA Number
Book value
Market Value
Appearance Remarks (code)
Notes
Status (code)
Breeder
Owner
Groups (code)
Calving Season (code)
Castrated (Yes/No)
Castration Date
Camp Movement Data:
Camp (code)
Date moved
Reason moved (code)
Vaccinations, Dosing and
Supplements Data:
Date Vaccinated
Vet
Vaccinated Against (code)
Vaccine (code)
Dosage
Cost
Remark

Diseases & Treatments Data:
Date Ill
Veterinarian Name
Illness/Injury (code)
Medicine/Treatment (code)
Remarks
Veterinarian Visit Data:
Veterinarian Visit Date
Veterinarian Name
Matings:
Calving Season (code)
Bull ID no
Multi Sire
Date In
Date Out
Pregnancy Data: (Females)
Testing Date
Pregnant (Yes/No)
Period Pregnant
Period Type [(W)eeks /
(M)onths]
Purchase Data:
Date Purchased
Seller
Price
Original ID no
Date Arrived on Farm
Sales, Deaths and Culls Data:
Sell/Death Date
Sold (Yes/No)
Reason for left Herd (code)
Sold To
Carcass Weigt
Price
Remarks
Date Left Farm
Animal Sightings Data:
Animal Sighting Date Seen By
Seen in Camp (code)
Remarks
GPS Longitute
GPS Latitude
Body Measurements Data:
Body Measurements Date
Shoulder Height
Hump Height
Head Length
Ear Length
Scrotum Circumference
Pelvic Height
Pelvic Width Front
Pelvic Width Back

Manure Samples Data:
Date Samples Taken
Parsite Type (code)
Number of Eggs per Gram
Remarks
Tooth Measurements Data:
Dentation Type (code)
Number of Teeth
Teeth Condition Score
Horn Measurements and Other
Data:
Horn Measurement Date
Horn Boss Width Left (Buffalo)
Horn Boss Width Right (Buffalo)
Horn Outside Spread (Buffalo)
Horn Inside Spread (Buffalo)
Inner Tip-Tip (Buffalol)
SCI Tip-Tip Length
SCI Index
Horn Length Left
Horn Length Right
Horn Base Circumference Left
Horn Base Circumference Right
Horn Tip-Tip Width
# Horn Rings Left
# Horn Rings Right
Horn Wear Left
Horn Wear Right
Horn Tip Length Left
Horn Tip Length Right
Front Horn Length Front (Rhino)
Front Horn Length Rear (Rhino)
Front Horn Circumference (Rhino)
Rear Horn Length Front (Rhino)
Rear Horn Length Rear (Rhino)
Rear Horn Circumference (Rhino)
Ring 1-10 Distance
Number of Turns (spirals)
Horn Spiral Width
Horn Drop Left (Buffalo)
Horn Drop Right (Buffalo)
Horn Boss Circumference Left
(BWB)
Horn Boss Circumference Right
(BWB)
# Body Stipes Left (Eland)
# Body Stipes Right (Eland)
Chevron (Eland)
Rainfall Data:
Date
Location
Amount (mm)
Remark
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Appendix B
SA Stud Book (Logix) as Service Provider –
Settings, Data Send and Data Import Functions
1.

Sending and importing Logix data:
Please note: This section is only applicable to herds which are members of SA Stud Book’s Logix
Game.
Because of the interdependency of BenguFarm GAME and data of animals on Logix, we will, where applicable,
refer to Logix, the internet access (www.logix.org.za) to the Logix database of SA Stud Book, and how Logix
fits in with BenguFarm GAME. For more information on Logix, contact Herman Labuschagne of SA Stamboek at
051 4100 900.
With BenguFarm GAME you can create and send electronic files for matings, birth notifications, horn
measurements, transfers and cancellations for capturing and processing on Logix. There are several options to
send data to Logix, but we recommend that the Logix Direct File Upload Functionality is used. To
enable it, go to Settings > Herds > Service Providers. Mark the option Use Logix Direct File Upload
Functionality, fill in your Logix username, password and your e-mail address and click Save. On the same
screen, also make sure the correct e-mail addresses are set up. (See paragraph 6, Settings > Herd Settings >
Service Providers). On the same screen, click on the General tab at the top of the screen and make sure the
Breed and Society/Studbook Member Number is set correctly in BenguFarm at Settings > Herds> General.
When set up like this, the existing Data Send functions which create electronic files will use Logix Direct
(instead of your e-mail programme) to send data to Logix.
You can then also import computer numbers, received by e-mail from Logix, into BenguFarm GAME to keep
your BenguFarm GAME database up to date with your herd’s data on the Logix database.
To make use of the Logix functions you must have a recorded e-mail address on Logix and be
marked "Yes" for Electronic Data Capture. [To check this, go to Logix (www.logix.org.za) and click on
Enquiries > Participation > Participant Details. If you are not a Logix user, you can complete an application online on the Logix home page at www.logix.org.za.] If you are not activated for electronic data, please contact
SA Stud Book on telephone number 051 4100 900 or send an e-mail to help@logix.co.za.

2.

Download and import Logix data:
If you are a Logix user, you can extract the data of your own animals and purchased animals from Logix for
importation into BenguFarm GAME – see the instructions below at paragraphs 11.1 and 11.2.
If you are not a Logix user, you can unfortunately not download data of animals (e.g. an AI bull or
purchased animals) from Logix. You can, however, log in as a guest on Logix and download sales catalogues
and certain other reports. If you want to import the Logix data of registered animals you purchased into
BenguFarm, please contact SA Stud Book at telephone number 051 4100 900 or send an e-mail to
help@logix.co.za and ask to send you the 5-generation Logix GAMEDATA file of the animal(s).
See paragraph 9 for other options to import new animals’ data.
If, for any reason, you are not able to import the applicable animals' data electronically into BenguFarm GAME,
you will have to create the records by hand from data you obtained from the seller or the information on
the sale catalogue. Please refer to paragraph 10 for instructions to do this.
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Note: To record new calvings/calves, see paragraph 20.

2.1

Download Logix data:
Please note:
• Newly bought animals:
o If Logix is not open for your particular species (so you only have access to
animals in your own herd), newly bought animals should be transferred to
your herd before you can download their data.
o If Logix is open, (so all breeders have access to all animals in the particular
species), newly bought animals’ data can be downloaded even before they
are transferred to your herd.
To download your entire herd’s Logix data:
▪ Go in Logix to Services > Data Extraction > Game Farm Software > Fill in your Participant
Code > Choose the species (if applicable) > Select the number of generations to be
included (we recommend selecting 5 generations) > Submit > Wait for the file to be
created.
▪ You now have the choice to download the data via one of two file formats, namely a csv
or a zip file format. The zip format is smaller and thus quicker to download. Right click on
the file of your choice and select Save Target As or Save Link As, depending the browser
you use). Save the file in a suitable place on your computer. (E.g.
C:\BenguFarm\Game\Imports\Herd).
Please note: Do NOT open this file in Excel, for this can result in you not being able
to import the data into BenguFarm GAME and/or dates may import incorrectly.
▪ See “Import Logix animal data” below for instructions to import this data into BenguFarm
GAME.
To download missing or specific animals’ Logix data:
• Option 1 – Logix Direct (recommended option for herds with SA Stud Book as service
provider):
▪ Please note: With this function you can only import data of animals already transferred
to your herd. To download and import data of animals NOT belonging to you (e.g. an AI
bull or animals bought but not transferred yet), see Option 2 below.
▪ To download and import missing animals’ data (e.g. animals recently bought and
already transferred to your name), go in BenguFarm GAME to Data Send/Import > Logix
Direct > Import Missing Animals.
▪ To download and import specific animals’ data, go in BenguFarm GAME to Data
Send/Import > Logix Direct > Import Animals. On this window you can specify the
computer number or the species, sex, HDM, year and sequence number of the animals to
be imported.
• Option 2:
▪ Go to the Logix website www.logix.org.za and log in with your username and
password. (If you are not a registered Logix user, you can apply online on the Logix home
page).
▪ Go in Logix to Services > Data Extraction > Game Farm Software > Choose Animals >
Create a new Group (give any suitable name to the group, e.g. Group 1) or Select an
Existing Group from the dropdown list, if applicable, and click Submit > Add Animal > Fill
in the animal’s computer number or ID number in the format Species
code/Sex/Year/Sequence No > Submit > Mark the animal in the box to the left of its No >
Add Animal to List [or Add Animal to List and choose more, if applicable] > Repeat until
all the applicable animals have been chosen and added to the list > Generate Report >
Select the number of pedigree generations to be included (we recommend you to choose
5 generations) > Submit > Wait for the file to be created.
▪ You now have the choice to download the data via one of two file formats, namely a csv
or a zip file format. The zip format is smaller and thus quicker to download. Right click on
the file of your choice and select Save Target As (or Save Link As, depending on the
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▪

browser you use). Save the file in a suitable place on your computer. (E.g.
C:\BenguFarm\Game\ Imports\Herd).
Please note: Do NOT open this file in Excel, for this can result in you not being able
to import the data into BenguFarm GAME and/or dates being imported incorrectly.
See “Import Logix Animal Data” below for instructions to import this data into BenguFarm
GAME.

Notes:
• If you have enquiries about Logix electronic data, please contact SA Stud Book on telephone
number 051 410 0900 or send an e-mail to help@logix.co.za.
• To change or add your e-mail address in Logix, or if you want to change or check your Electronic
Data Capture status, please contact Philna Moelich at telephone number 051 410 0900 or send an
e-mail to philna@studbook.co.za.

2.2

Import Logix animal data into BenguFarm GAME:
•
•
•

•
•

•

3.

Before you proceed to import the data into BenguFarm GAME, please make a backup of your
BenguFarm GAME database (File > Backup and Restore > Backup).
Go in BenguFarm GAME to File > Change Active Herd To and select the herd in which the data
should be imported.
Go to Data Send/Import > Import > Database > Logix Main Data File. Browse for the
csv or zip format data file (GAMEDATA_...) where you saved it. Please note: The zip file format
can be imported directly, without the need to extract the data. Make sure the Stud Book/ARC
Member No (seven characters, e.g. 0567890), HDM and Species are completed. Select the
relevant importation options (The default options are usually in order) and click on Import. Please
note the Delete Bull Progeny of Other Owners option to remove the progeny of bulls (such
as AI bulls) born in other herds during the importing to prevent unnecessary animals from being
imported into the database. Use the Help function if necessary.
Go to File > Support and run Remove DB Null Values and Recalculate Summary Information.
To check if the animal data has been imported correctly, click on the arrow next to the white block
on the main window and look if the animals that were imported appear on the “Active” list.
Please note:
o If the Stud Book Member No was entered incorrectly when you imported the data, the active
animals will be listed incorrectly with status as “Non-active”. To set the Stud Book Member No
in BenguFarm GAME, go to Settings > Herds > General > Society (Stud Book) Member No.
o Animals which were not yet transferred to your herd when you’ve downloaded the data
via Logix will be listed in the non-active animals list after you have imported the data into
BenguFarm GAME. To move the animals to the active list, switch on the “Non-active” filter,
find the particular animal(s) on the list, go to Animals > Add and Edit Animals window and
change in the Status field from “Non-active” to “Active”.
o If you also do not find a relevant animal(s) with the non-active animals, make sure that the ID
number is not, for example, ABC 180038 (with a space after the HDM) instead of ABC180038.
Try searching for the animal on computer number at Animals > Search Animal.
o To ensure that breeding bulls are displayed on top of the list of bulls on the Natural
Matings/AI window, go to the Add and Edit Animals window, find the applicable bull and
mark (highlight) the bull. Make a tick mark in the field "Breeding/AI Bull" and click Save.
Please note: The field "Breeding/AI Bull" will only be displayed if the applicable animal is a
male.
If you have previously recorded the animals in question manually on BenguFarm, make sure
that no duplicate animal records have been created with importing of the Logix data.
To find duplicate animals, see paragraph 35.

Send matings:
•
•

After the mating data have been captured in BenguFarm GAME (Reproduction > Matings) the mating data
should be sent to the SA Stud Book to capture this data on the Logix database.
To send the mating data in electronic format (csv) to SA Stud Book (or to print it if you do not
have the facilities to send data in electronic format), go to Data Send/Import > Send > Stud Book/ARC >
Matings. Select the matings you want to send and click on List Matings according to Selection Criteria.
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•
•

•

•
•
•

4.

Check if there are any errors. To display the error description, move the computer's cursor over the
column heading. If there are Errors, you first have to fix it, because BenguFarm GAME will NOT allow you
to send matings and/or AI data if there are any errors. Use the Help function if necessary.
If you are sure all data is correct and complete, click on Create Electronic File to create and send an
electronic file of the selected matings. If the Use Logix Direct File Upload Functionality (see Settings >
Herds > Service Providers) or use SMTP Direct E-mail option (see Settings > Herds > E-mail) is selected,
the electronic file will be sent directly (i.e. not through your e-mail program) to Logix. If not, BenguFarm
GAME will now attempt to automatically attach the electronic data file to an e-mail message and put it into
the Outbox of your default e-mail programme (e.g. Outlook). The e-mail will be sent when you are on-line.
If, for some or other reason, BenguFarm GAME cannot send the electronic file, a warning message will
appear. Please note where you save the file to be attached to an email (e.g. C:\BenguFarm\Game\
Exports\Herd of C:\Program Files\BenguelaSoft\BenguFarm\Electronic\Send). Please follow the instructions
on the warning message for help on how to create an e-mail with your e-mail programme (e.g. Outlook)
yourself, attach the applicable file to it and send it to edata@studbook.co.za. Note: Remember where you
have saved the file for attaching it to an email. [For help to solve problems with the sending of data,
contact you BenguFarm agent].
When the data has been received, Logix will automatically send you an e-mail message as proof of receipt.
If you have not, for some or other reason, received such an e-mail, please contact SA Stud Book on
telephone number 051 410 0900 or send an e-mail to help@logix.co.za.
If you do not have the facilities to send data in electronic format, you can print it and send it by fax or
normal mail. To print the matings and/or AI data, click on Display Printout > Print.
To check which matings were already send, go to Reports > Administration > Log of Files and
Reports Sent.

Send birth notifications:
•
•
•

•

•

•

After the calvings/births have been captured in BenguFarm GAME (Reproduction > Calvings) this data
should be sent to SA Stud Book to capture this data on the Logix database.
To send new births in electronic format to SA Stud Book (or to print it if you do not have the
facilities to send data in electronic format), go to Data Send/Import > Send > Stud Book/ARC > Birth
Notifications. Click on List New Births.
To resend births that have already been sent (e.g. after corrections have done on the birth data in
BenguFarm), go to Data Send/Import > Send > Studbook/ARC > Birth Notifications. Remove the check
mark Include Animals with Computer Numbers From the option at the top left of the screen. Click on
Select Animals and select the calf in question. Under Options, mark Animal Update (U) instead of Birth
Notification (B). Use the Help function if necessary.
Check if the Options are correct for the applicable animals. Also check if there are any Errors/Missing
Data or Warnings. By moving the computer’s cursor across the applicable column heading, it will show
you the details of the error/missing data or warning. If there are any errors and/or missing data,
BenguFarm GAME will NOT allow you to send birth notifications. The Warnings are only intended to make
you aware of possible errors or problems, but you can send the birth notifications despite the warnings. To
print a report of the errors and/or missing Data, click on Print Errors Report. To fix errors or missing data,
click next to the animal on the three dots in the “i” column to open the Add and Edit Animals window.
If you are sure all data is correct and complete, click on Create Electronic File to create and send an
electronic file of the selected calves’ birth notifications. If the Use Logix Direct File Upload Functionality
(see Settings > Herds > Service Providers) or use SMTP Direct E-mail option (see Settings > Herds > Email) is selected, the electronic file will be sent directly (i.e. not through your e-mail program) to Logix. If
not, BenguFarm GAME will now attempt to automatically attach the electronic data file to an e-mail
message and put it into the Outbox of your default e-mail programme (e.g. Outlook). The e-mail will be
sent when you are on-line.
If, for some reason, BenguFarm GAME cannot send the electronic file, a warning message will appear.
Please note where you save the file to be attached to an email (e.g. C:\BenguFarm\Game\Exports\Herd or
C:\Program Files\BenguelaSoft\BenguFarm\Electronic\Send). Please follow the instructions on the warning
message for help on how to create an e-mail with your e-mail programme (e.g. Outlook) yourself, attach
the applicable file to it and send it to edata@studbook.co.za. Note: Remember where you have saved the
file for attaching it to an email. [For help to solve problems with the sending of data, contact you
BenguFarm agent].

51

•
•
•

5.

Import computer numbers:
•
•

•

•

6.

When the data has been received, Logix will automatically send you an e-mail message as proof of receipt.
If you have not, for some or other reason, received such an e-mail, please contact SA Stud Book on
telephone number 051 410 0900 or send an e-mail to help@logix.co.za.
If you do not have the facilities to send data in electronic format, you can print it and send it by fax or
normal mail. To print birth notifications, click on Display Printout > Print.
To check which birth notifications were already send, go to Reports > Administration > Log of Files
and Reports Sent. Please note: Once the electronic file is created, BenguFarm logs the file in question as
sent. Therefore, if the data could not be sent directly or via your email, it will still be logged as sent, since
the file was created. The best proof that the birth notifications were received by Logix, is the receipt
acknowledgment email you should receive from Logix.

When the birth notifications have been captured and processed on Logix, Logix again automatically sends
you an e-mail message, as proof of capture and processing. Attached to this e-mail is an electronic file
(BIRTHS_...) which you will need to import the computer numbers into BenguFarm GAME.
Note: If you did not, for some or other reason, receive the e-mail from Logix, you can acquire the
electronic file concerned by going to the Logix website (www.logix.org.za) and clicking on the left-hand
side of the window on Messages. The electronic files that were sent to you are saved there according to
the date of capture/processing.
To import missing computer numbers into BenguFarm GAME, there are two options:
o Option 1 – Logix Direct (recommended option):
▪
Go to Data Send/Import > Logix Direct > Import Missing Computer Numbers. An option to
update the sections of PEN (pending) animals is available.
o Option 2:
▪
Save
the
electronic
file
at
a
suitable
place
on
your
computer
(e.g.
C:\BenguFarm\Game\Imports\... – see Settings > Herds > Default Folders for Files]. This can be
done in Outlook by clicking on File > Save Attachment or otherwise by right clicking on the file
and choosing Save Target As. Make a note of where the file is saved. [Please note: Do NOT
open this file in Excel and save in xls or csv format, for this will result in you not being able to
import the data into BenguFarm GAME and/or the dates may import incorrectly].
▪
In BenguFarm GAME go to Data Send/Import > Import > Stud Book/ARC > Animal Computer
Numbers, browse for the particular electronic file (BIRTHS...) and click on Import. [Use the
Help function if necessary]. Please Note: BenguFarm GAME uses the animal's HDM, Year,
Sequence Number, Sex and Breed to link the relevant animal in the BIRTHS ... file with the
animal in the BenguFarm GAME database. Animals with "UNKNOWN" in the “Animal in
BenguFarm GAME" column's computer number will NOT be imported. To link an unknown
animal by hand to the correct animal in BenguFarm GAME, click on the "UNKNOWN" and select
the appropriate animal from the list.
To create a report of animals without computer numbers, go to Reports> Administration> Animals
without Computer Numbers.

Send horn and other measurements:
•

•
•
•
•

After the horn measurements and other data (other measurements, microchip number, etc.) have been
captured in BenguFarm GAME [Other Data > Darting Data > General or Performance Testing > Weights
and Recordings not linked to a Test > Traits], this data should be sent to Stud Book to capture this data
on the Logix database.
To send the Darting Data in electronic (csv) format to Stud Book (or to print it if you do not have
the facilities to send data in electronic format), go to Data Send/Import > Send > Stud Book/ARC >
Darting Data.
Select the applicable animals and measurements according to the selection criteria. Use the Help function
if necessary.
Check if there are any errors – see the columns on the left side of the screen. To display the description
of an error, move the computer's cursor over the column heading. BenguFarm GAME will NOT allow you to
send horn and other measurements data if there are errors and/or missing data.
If you are sure all data is correct and complete, click on Create and Send Electronic File of Data to
Service Provider / Create Electronic File to create and send an electronic file of the selected Darting
Data. If the Use Logix Direct File Upload Functionality (see Settings > Herds > Service Providers) or use
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SMTP Direct E-mail option (see Settings > Herds > E-mail) is selected, the electronic file will be sent
directly (i.e. not through your e-mail program) to Logix. If not, BenguFarm GAME will now attempt to
automatically attach the electronic data file to an e-mail message and put it into the Outbox of your
default e-mail programme (e.g. Outlook). The e-mail will be sent when you are online.
If, for some or other reason, BenguFarm GAME cannot send the electronic file, a warning message will
appear. Please note where you save the file to be attached to an email (e.g. C:\BenguFarm\Game\
Exports\Herd or C:\Program Files\BenguelaSoft\BenguFarm\Electronic\Send). Please follow the
instructions on the warning message for help on how to create an e-mail with your e-mail programme
(e.g. Outlook) yourself, attach the applicable file and send it to edata@studbook.co.za (SA Stud Book).
Note: Remember where you have saved the file for attaching it to an email. [For help to solve problems
with the sending of data, contact you BenguFarm agent].
When the data has been received, Logix will automatically send you an e-mail message as proof of receipt.
If you have not, for some or other reason, received such an e-mail, please contact SA Stud Book on
telephone number 051 410 0900 or send an e-mail to help@logix.co.za.
To check which Darting Data were already send, go to Reports > Administration > Log of Files and
Reports Sent.

Send transfers and cancellations:
•

•

•

•

•

•

•

After the sales and/or deaths have been captured in BenguFarm GAME (Other Data > Sales, Deaths and
Culls), this data should be sent to SA Stud Book (if you are a stud breeder to transfer the animals to the
new owner and/or remove them from your herd’s inventory on Logix. Please note: To send a transfer to
Logix, the buyer should be selected in the Sold To field from the Contact list and the contact should,
except for the Business name, also contain the Stud Book member number OR an address to ensure the
animal is transferred to the correct new owner.
To send the transfer and/or cancellation notifications electronically to SA Stud Book/ARC (or
to print if you do not have the facilities to send data in electronic format) directly from the Sales, Deaths
and Culls screen, click at the bottom left of the screen on the Create and Send Electronic Data File to
Service Provider icon. If the records are not already on the screen, first click Load Existing Records and
select the records to be sent.
Alternatively go to Data Send/Import > Send > Stud Book/ARC > Transfers and Cancellations. Click on
List Transfers and Cancellations Not Sent Before. If the applicable transfers and/or cancellations have
already been sent or printed and you need to send them again for whatever reason, click on Select
Animals. Use the Help function if necessary.
Check if the Options are correct for the applicable animals. Also check if there are any Errors. To display
the description of an error, move the computer's cursor over the column heading. If so, make a note of
the animal(s) involved and the problem. To correct this, click on the three dots in the “$” column. Please
note: If animals have been sold and the Sale (Transfer) field was marked, the buyer's address and/or
Studbook member number (e.g. 0678678SBL) must be filled in on the buyer's contact. To fill it in or
change it, click on the three dots in the Contacts column.
If you are sure all data is correct and complete, click on Create and Send Electronic File of Data to
Service Provider / Create Electronic File (icon with red and blue arrows at the bottom of the window)
to create and send an electronic file(s) of the selected cancellations and/or transfers. If the Use Logix
Direct File Upload Functionality (see Settings > Herds > Service Providers) or Use SMTP Direct E-mail
option (see Settings > Herds > E-mail) is selected, the electronic file will be sent directly (i.e. not through
your e-mail program) to Logix. If not, BenguFarm GAME will now attempt to automatically attach the
electronic data file to an e-mail message and put it into the Outbox of your default e-mail programme (e.g.
Outlook). The e-mail will be sent when you are on-line.
If, for some or other reason, BenguFarm GAME cannot send the electronic file, a warning message will
appear. Please note where you save the file to be attached to an email (e.g.
C:\BenguFarm\Game\Exports\Herd of C:\Program Files\BenguelaSoft\BenguFarm\Electronic\Send). Please
follow the instructions on the warning message for help on how to create an e-mail with your e-mail
programme (e.g. Outlook) yourself, attach the applicable file(s) to it and send it to edata@studbook.co.za
(SA Stud Book). Note: Remember where you have saved the file for attaching it to an email. [For help to
solve problems with the sending of data, contact you BenguFarm agent].
When the data has been received, Logix will automatically send you an e-mail message as proof of receipt.
If you have not, for some or other reason, received such an e-mail, please contact SA Stud Book on
telephone number 051 410 0900 or send an e-mail to help@logix.co.za.
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If you do not have the facilities to send data in electronic format, you can print it and send it by fax or
normal mail. To print the cancellations, click on Display Cancellations Printout > Print. To print transfers,
click on Display Transfers Printout > Print.
To check which matings were already send, go to Reports > Administration > Log of Files and
Reports Sent.
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Appendix C
Calculations in BenguFarm-GAME –
Descriptions and General Guidelines for Selection
Trait
General
Age of Animal

When is calf considered
as being weaned?
Reproduction
Expected Calving Date

Description
The age of animal is displayed on the main screen as follow:
• 0 - 634 days in Days
• 635 - 730 days in Months
• 731+ days in Years.
The age of animal is displayed on the main screen’s Horn Measurements view
window as follow:
• 0 - 3 months in Days
• 4 - 24 months in Months
• 25+ months in Years
A calf is considered weaned if a Wean procedure has been recorded (Other Data >
Procedures).
Expected calving date calculations in BenguFarm depends firstly on whether a
pregnancy test was done or not for the particular animal:
1. If a pregnancy test was done, the animal was pregnant and the period pregnant
was recorded in BenguFarm, the expected calving date is calculated as follows:
Testing date MINUS Period pregnant on testing date PLUS Normal pregnancy
period (as set up at Settings > Herds > Matings, Pregnancy and calving).
2. If no pregnancy test was done OR a pregnancy test was done, the animal was
found pregnant but the period pregnant has not been recorded in BenguFarm,
the expected calving date calculation depends on whether matings were
recorded in BenguFarm or not:
2.1. If matings were recorded (as is normally the case in cattle and sheep where
mating seasons are used), the earliest possible calving date (if selected at
Settings > Herds > Matings, Pregnancies & Calving > Calculate First
Possible Expected Calving Date) is calulated as follows: The first mating date
since the last calving date OR where several pregnancy tests have been
done since the last calving date, the first mating since the previous
pregnancy test PLUS Normal pregnancy period.
2.2. With the setting "Calculate Expected Calving dates without Mating Data"
[Settings > Herds > Matings, Pregnancies & Calving] enabled (it is enabled
by default for the GAME module), the expected calving date is calculated
without any mating data or pregnancy tests recorded in the program.
2.2.1. For heifers older than "Minimum Age of Heifers at 1st Mating"
(Settings > Herds > Matings, Pregnancy and Calving) the expected
calving date is calculated as date of “Minimum Age of Heifers at 1st
Mating” PLUS the "Normal Period Pregnant".
2.2.2. For cows with days since last calving date more than the "Av. Period
from Calving to Mated again" (Settings > Herds > Matings, Pregnancy
and Calving) the expected calving date is calculated as the last calving
date PLUS the "Av. Period from Calving to Mated again" (if > 0, else
the "Ovulation Period") PLUS the "Normal Pregnancy Period”. This
calculation is displayed on the main window and My Reports (Last
Mating - No mating data but expected calving dates), Heifers and
Cows Near Calving report, if "Minimum days since last calving (no
matings)" is marked (default marked in the GAME module), and the
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Heifers and Cows Calved/Not Calved" report. This method thus
calculates the earliest possible calving date. By changing the default
“Minimum Age of Heifers at 1st Mating” and/or the "Av. Period from
Calving to Mated again" settings, the expected calving date
calculation can be made more accurate.
Trait
Description
Guidelines for Selection
Age Last Calving
Age (in months) when the cow calved for the Not normally used in selection – only
(ALC)
last time.
informative info.
First Inter-calving Period Period (in days) between first and second
Cull cows with a high first inter(First ICP)
calving dates.
calving period, taken into
consideration when they were
mated for the first time and the
second time.
Last Inter-calving Period Period (in days) between the last two calving Cull cows with a high last inter(Last ICP)
dates.
calving period.
Av Inter-calving Period
Average period (in days) between calvings
Cull cows with a high average inter(Av ICP)
over all the calving dates.
calving period.
Days Since Last Calving The period (in days) since the last calving
Cull cows with a high Days Since
(DSLC)
date.
Last Calving value.
Reproduction Index
The RI evaluates the overall reproduction
Cull cows with a low Reproduction
(RI)
performance of a cow, taking AFC and
Index.
average ICP into account. Please note that
DSLC is, for technical reasons, not taken into
account in the calculation of the RI.
Using the RI, cows with different AFC and
ICPs can directly be compared, e.g. a cow
that calved at 24, 48 and 60 months of age
will have the same RI as a cow that calved at
36, 48 and 60 months of age.
Horn Measurements
Contemporaries
A contemporary group is a group of animals
The number of contemporaries gives
(Contemp.)
born in the same year and season (thus of
an indication of the reliability of the
similar age), at the same location (same herd horn growth index calculations: The
or farm), of the same sex, and fed and
more the contemporaries, the more
managed alike from birth to the time of
reliable the indexes.
measurement.
Please note: Correctly defined
contemporary groups are essential
It is of UTMOST IMPORTANCE that all horn
for accurate comparison of animal’s
growth indexes (see Reports > Weights,
performance regarding horn growth
Measurements,… > Horn Measurements
and future breeding value
Evaluation) are calculated within a
estimations. Contemporary groups
contemporary group (see above).
should be defined in such a way that
all (or at least all significant)
environmental effects are the same
for all animals within a particular
group.
Horn Growth per Month The average horn growth (in inches,
Use the Horn Growth Index for
(inch/ md or mm /
centimeters or mm as set up at Settings >
selection - see below.
month or cm / month)
Traits per Species) per month from birth to
the time of measurement.
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Horn Growth Index

Corrected Horn Length

Horn Growth between
measurements (inch/
md or mm / month or
cm / month)
Body Measurements
Adjusted Scrotum
Circumference
(Adj. SC)
Adjusted Scrotum is not
yet calculated in
BenguFarm-GAME.

Horn Growth Index is calculated by dividing
the animal's horn growth per month from
birth to measurement date value by the
average horn growth off of the particular
group (contemporaries within gender),
expressed as a percentage.
A horn growth index of 110 thus means that
the animal's horn grew 10% faster than the
average of the group in which he or she was
compared.
Currently Corrected Horn Length in
BenguFarm-GAME is only calculated for Sable.
The user can select to which age (e.g. 365
days) the horn length should be corrected (or
projected). The Corrected Horn Length makes
it possible to compare animals’ horn lengths
at the same age.
The average horn growth per month from the
previous to the current measurement. This
calculation is only available on the Horn
Measurements view screen on the main
window. To enable this option, go to Display
> Horn Measurements View Screen Options.

The Horn Growth Index makes it
easy to compare animals’ horn
growth within a contemporary
group. To select for animals with
above average horn growth, select
animals with a Horn Growth Index
of above 100 within the particular
contemporary group.

Scrotum circumference is an indirect
evaluation of testes volume. Larger testes are
associated with a larger volume of semen
production and also, to a lesser extent, with
higher quality of semen.

Cull bulls with low (10% or more
below average) Adjusted Scrotum
Circumference (e.g. herd average =
340mm – cull bulls with an Adjusted
Scrotum Circumference below
315mm).

To select for animals with above
average horn length, select animals
with a Horn Growth Index of above
100
within
the
particular
contemporary group.
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Appendix D
Contact details
For enquiries and assistance with regards to BenguFarm GAME, please contact your assigned agent.
NAME
Leslie Bergh
Naomi Havenga
Johan de Jager
Martiens Aveling
Erick Joosten
International dialing

CAPACITY
Project Leader & Agent
Registration of Software
Agent
Agent
Agent
code for South Africa: +27

OFFICE
Pretoria
Pretoria
Potchefstroom
Bethlehem
Somerset West

CELL NR
082 801 2026
082 696 8306
083 305 1042
083 309 7355
082 204 2379

E-MAIL
bengufarm@gmail.com
havenga.naomi@gmail.com
jjager@mweb.agric.za
aveling@telkomsa.net
erickjoosten@gmail.com

Website: www.bengufarm.co.za
BenguFarm agents use Teamviewer software for remote (Internet) support. Teamviewer can, if installed, be
opened from BenguFarm on the main screen by going to Help > Teamviewer Remote Support. If not installed,
Teamviewer can be downloaded and installed at www.teamviewer.com. If you need support using Teamviewer, open
your Teamviewer (make sure your Internet connection is turned on), contact your BenguFarm agent and provide your
Teamviewer ID and password to him/her.

Training courses and individual training
BenguFarm GAME users are notified by e-mail BenguFarm News of the dates, places and other details when training
courses are organised. His information is also put on the website www.bengufarm.co.za > Training.
For individual or small group (1-3 persons) or online training, contact your BenguFarm agent or contact Mr. Leslie
Bergh at 082 801 2026 or e-mail bengufarm@gmail.com or Mr. Johan de Jager at 083 305 1048 or e-mail
jjager@mweb.co.za.
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